summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas stig124 FORMICHELLA2021-09-02 18:09:22 +0200
committerNicolas stig124 FORMICHELLA2021-09-02 18:09:22 +0200
commite52386b8055057481024c07431ddb101c1907ecd (patch)
tree373e66ed78108108e41e4a3bcc9e8c8ea3799b32
downloadaur-e52386b8055057481024c07431ddb101c1907ecd.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--.install3
-rw-r--r--69-n-link.rules4
-rw-r--r--PKGBUILD40
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..819430f35b52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = n-link
+ pkgdesc = Free, cross-platform, CX-II compatible computer linking program for the TI-Nspire.
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://lights0123.com/n-link/
+ arch = x86_64
+ license = GPL3
+ depends = nodejs-lts-fermium
+ depends = webkit2gtk
+ depends = squashfs-tools
+ provides = n-link
+ conflicts = n-link-git
+ noextract = n-link_0.1.6_amd64.deb
+ source = https://github.com/lights0123/n-link/releases/download/v0.1.6/n-link_0.1.6_amd64.deb
+ source = 69-n-link.rules
+ sha256sums = 85afe0a52ee8f1bd0c7d61f3cbac5d24db89963d11e942c330a968125f8051e2
+ sha256sums = 08274e4c02e4321f352412af6d539a33151c6136cace924b29150520ccd79e7d
+
+pkgname = n-link
diff --git a/.install b/.install
new file mode 100644
index 000000000000..0d5d587529e4
--- /dev/null
+++ b/.install
@@ -0,0 +1,3 @@
+post_install() {
+ udevadm control --reload-rules && udevadm trigger
+}
diff --git a/69-n-link.rules b/69-n-link.rules
new file mode 100644
index 000000000000..351a9b115b89
--- /dev/null
+++ b/69-n-link.rules
@@ -0,0 +1,4 @@
+# TI-Nspire
+SUBSYSTEM=="usb", ATTR{idVendor}=="0451", ATTR{idProduct}=="e012", ENV{ID_PDA}="1"
+# TI-Nspire CX II
+SUBSYSTEM=="usb", ATTR{idVendor}=="0451", ATTR{idProduct}=="e022", ENV{ID_PDA}="1"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eed98e0aaa8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=n-link
+pkgver=0.1.6
+pkgrel=1
+epoch=
+pkgdesc="Free, cross-platform, CX-II compatible computer linking program for the TI-Nspire."
+arch=("x86_64")
+url="https://lights0123.com/n-link/"
+license=('GPL3')
+groups=()
+depends=("nodejs-lts-fermium" "webkit2gtk" "squashfs-tools")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=("n-link")
+conflicts=("n-link-git")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/lights0123/${pkgname}/releases/download/v${pkgver}/${pkgname}_${pkgver}_amd64.deb"
+ "69-${pkgname}.rules")
+noextract=("${pkgname}_${pkgver}_amd64.deb")
+sha256sums=('85afe0a52ee8f1bd0c7d61f3cbac5d24db89963d11e942c330a968125f8051e2'
+ '08274e4c02e4321f352412af6d539a33151c6136cace924b29150520ccd79e7d')
+validpgpkeys=()
+
+package() {
+ ar p "${pkgname}_${pkgver}_amd64.deb" data.tar.gz | bsdtar -C "${pkgdir}" -xf -
+ find "${pkgdir}" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/usr/bin/" -type f -executable -exec chmod 755 {} \;
+ mkdir -p "${pkgdir}/etc/udev/rules.d/"
+ install -Dm644 "69-${pkgname}.rules" "${pkgdir}/etc/udev/rules.d/69-${pkgname}.rules"
+}