summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormoyiz2023-12-08 09:24:04 +0000
committermoyiz2023-12-08 09:24:04 +0000
commit22fd8720f0287037c7c4723e9ef998b52401e931 (patch)
tree2b3a433f798697a3afb97a97f3447e7d3e40a7f7
downloadaur-22fd8720f0287037c7c4723e9ef998b52401e931.tar.gz
Update to v0.0.2
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51e356537ac8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = na-bin
+ pkgdesc = CLI tool to effortlessly manage context aware nested shortcuts for shell commands.
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/moyiz/na
+ license = BSD-3-Clause
+ depends = glibc
+ conflicts = na
+ provides = na
+ arch = aarch64
+ source_aarch64 = https://github.com/moyiz/na/releases/download/v0.0.2/na_linux_arm64.tar.gz
+ sha256sums_aarch64 = 63675d9af74179a457db6ffc499acb60e96a89765d60629b17010ba328d7b94a
+ arch = i686
+ source_i686 = https://github.com/moyiz/na/releases/download/v0.0.2/na_linux_i386.tar.gz
+ sha256sums_i686 = 19be46d576b5b29e6544e36c49ef45b21576914bb05c2e5043f7bbd55ae0fbca
+ arch = x86_64
+ source_x86_64 = https://github.com/moyiz/na/releases/download/v0.0.2/na_linux_x86_64.tar.gz
+ sha256sums_x86_64 = b4ef80783215da28d9e347ab5b5b5dd775e4069a96d1f523da8c5519254cb727
+
+pkgname = na-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e3d0ca7e1ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: moyiz <8603313+moyiz@users.noreply.github.com>
+# Contributor: moyiz <8603313+moyiz@users.noreply.github.com>
+
+pkgname='na-bin'
+pkgver=0.0.2
+pkgrel=1
+pkgdesc='CLI tool to effortlessly manage context aware nested shortcuts for shell commands.'
+url='https://github.com/moyiz/na'
+arch=('aarch64' 'i686' 'x86_64')
+license=('BSD-3-Clause')
+provides=('na')
+conflicts=('na')
+depends=('glibc')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/moyiz/na/releases/download/v0.0.2/na_linux_arm64.tar.gz")
+sha256sums_aarch64=('63675d9af74179a457db6ffc499acb60e96a89765d60629b17010ba328d7b94a')
+
+source_i686=("${pkgname}_${pkgver}_i686.tar.gz::https://github.com/moyiz/na/releases/download/v0.0.2/na_linux_i386.tar.gz")
+sha256sums_i686=('19be46d576b5b29e6544e36c49ef45b21576914bb05c2e5043f7bbd55ae0fbca')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/moyiz/na/releases/download/v0.0.2/na_linux_x86_64.tar.gz")
+sha256sums_x86_64=('b4ef80783215da28d9e347ab5b5b5dd775e4069a96d1f523da8c5519254cb727')
+
+package() {
+ cd ${srcdir}
+ install -Dm755 na ${pkgdir}/usr/bin/na
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
+
+ declare bash_comp=${pkgdir}/usr/share/bash-completion/completions/
+ declare zsh_comp=${pkgdir}/usr/share/zsh/site-functions/
+ declare fish_comp=${pkgdir}/usr/share/fish/vendor_completions.d
+
+ mkdir -p completions ${bash_comp} ${zsh_comp} ${fish_comp}
+
+ ./na completion bash > ./completions/na.bash
+ ./na completion zsh > ./completions/na.zsh
+ ./na completion fish > ./compleions/na.fish
+
+ install -Dm644 ./completions/na.bash ${bash_comp}/na
+ install -Dm644 ./completions/na.zsh ${zsh_comp}/_na
+ install -Dm644 ./completions/na.fish ${fish_comp}/na.fish
+}