summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Douglas Scott2020-12-16 21:37:20 -0800
committerIan Douglas Scott2020-12-16 21:37:20 -0800
commit2d60797bc030fba4ef1e94da7cb223161cbd92b1 (patch)
treec5f9e7029c7866a7852c5c4fc7e566df820e961b
parent8a50a8909de9ac9dcedf28b416fe054237e00507 (diff)
downloadaur-2d60797bc030fba4ef1e94da7cb223161cbd92b1.tar.gz
Compile with meson
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 235eca1b8f61..d55cb695d0de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=naev-git
_pkgname=naev
pkgdesc="2d action/rpg space game similar to Escape Velocity, development branch"
-pkgver=v0.8.0.beta.3
+pkgver=v0.8.0.r177.gcbeb2c498
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
license=('GPL')
url="http://naev.org/"
-depends=('sdl2_image' 'sdl2_mixer' 'libxml2' 'freetype2' 'libpng' 'openal' 'libvorbis' 'binutils' 'libgl' 'libzip' 'luajit')
+depends=('sdl2_image' 'sdl2_mixer' 'libxml2' 'freetype2' 'libpng' 'openal' 'libvorbis' 'binutils' 'libgl' 'libzip' 'luajit' 'suitesparse')
makedepends=('git' 'intltool' 'zip' 'itstool' 'autoconf-archive' 'fontconfig' 'glu')
provides=('naev' 'naev-data')
conflicts=('naev' 'naev-data')
@@ -25,14 +25,12 @@ pkgver() {
build() {
cd $srcdir/$_pkgname
- ./autogen.sh
- ./configure --prefix=/usr
-
- make
+ meson build --prefix /usr
+ meson compile -C build
}
package() {
cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}