summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan D. Scott2015-04-05 15:56:58 -0700
committerIan D. Scott2015-04-05 15:56:58 -0700
commite1abda2d2bc608402babd76ac356f3f4b3c87101 (patch)
treee15bf58d7b465915b57d927fd6d9366daec86362
downloadaur-e1abda2d2bc608402babd76ac356f3f4b3c87101.tar.gz
Commit adopted and updated naev-git PKGBUILD
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD38
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc5b6364e0dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = naev-git
+ pkgdesc = 2d action/rpg space game similar to Escape Velocity, development branch
+ pkgver = 0.3.8.r9579.g166f0ed
+ pkgrel = 1
+ url = http://naev.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = libxml2
+ depends = freetype2
+ depends = libpng
+ depends = openal
+ depends = libvorbis
+ depends = binutils
+ depends = libgl
+ depends = libzip
+ provides = naev
+ provides = naev-data
+ conflicts = naev
+ conflicts = naev-data
+ source = git://github.com/naev/naev.git
+ md5sums = SKIP
+
+pkgname = naev-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..496f63a12801
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Ian D. Scott <ian@perebruin.com>
+# Contributor: John Pate <jkpate@jkpate.net>
+
+pkgname=naev-git
+_pkgname=naev
+pkgdesc="2d action/rpg space game similar to Escape Velocity, development branch"
+pkgver=0.3.8.r9579.g166f0ed
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://naev.org/"
+depends=('sdl2_image' 'sdl2_mixer' 'libxml2' 'freetype2' 'libpng' 'openal' 'libvorbis' 'binutils' 'libgl' 'libzip')
+makedepends=('git')
+provides=('naev' 'naev-data')
+conflicts=('naev' 'naev-data')
+
+source=('git://github.com/naev/naev.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed -r 's/^NAEV-//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/$_pkgname
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ make DESTDIR="$pkgdir" install
+}