aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Grimes2019-04-12 15:52:38 -0400
committerMark Grimes2019-04-12 15:52:38 -0400
commitc8b3d2672a066c34af0bc501717ab225bbfb572d (patch)
tree9a1b1a573422f46f1f0191cf4d1f463aa8697817
parent139bfaf4ecadf87f15d81b438947593a193f6324 (diff)
downloadaur-c8b3d2672a066c34af0bc501717ab225bbfb572d.tar.gz
Upgrades to version 3.2.1 and enables builtin SSL support
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8ff3e69df482..094ba4bd0bcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,31 @@
# https://github.com/mvgrimes/aur-nagios-npre-plugin
pkgname=nagios-nrpe-plugin
-pkgver=2.15
-pkgrel=5
+pkgver=3.2.1
+pkgrel=1
pkgdesc="The Nagios Server NRPE plugin (install on the monitoring machine)."
license=('GPL')
arch=('any')
url="http://www.nagios.org"
source=("http://downloads.sourceforge.net/nagios/nrpe-${pkgver}.tar.gz")
-md5sums=('3921ddc598312983f604541784b35a50')
+md5sums=('8997e195fea93cdceb8c7ed8ac1d43bc')
depends=(nagios)
install=nagios-nrpe-plugin.install
+# nagios already depends on openssl-1.0
+
build() {
cd ${srcdir}/nrpe-${pkgver}
- ./configure --prefix=/usr/share/nagios \
- --with-nagios-user=nagios --with-nagios-group=nagios || return 1
- make || return 1
+ ./configure \
+ --prefix=/usr/share/nagios \
+ --enable-ssl \
+ --with-nagios-user=nagios \
+ --with-nagios-group=nagios \
+ || return 1
+ make nrpe || return 1
}
package() {
cd ${srcdir}/nrpe-${pkgver}
- make prefix=${pkgdir}/usr/share/nagios install-plugin || return 1
+ make DESTDIR=${pkgdir} install-plugin || return 1
}