aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Grimes2015-06-08 12:10:30 -0400
committerMark Grimes2015-06-08 12:12:11 -0400
commitda076b7cd3ca297ffbb1c0547eee4906a46c0f86 (patch)
treeca8b25babd4600770f193656401f03aad09f7100
parent48bfe10c6c383b441de6dcff06c0dc1160fef9ee (diff)
downloadaur-da076b7cd3ca297ffbb1c0547eee4906a46c0f86.tar.gz
Upgrades to 2.15 and aur 4
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
-rw-r--r--README2
-rw-r--r--nagios-nrpe-plugin.install11
5 files changed, 27 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 309dd1b0b944..7e18ab18880e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = nagios-nrpe-plugin
pkgdesc = The Nagios NRPE server side plugin.
- pkgver = 2.14
- pkgrel = 1
+ pkgver = 2.15
+ pkgrel = 3
url = http://www.nagios.org
- arch = i686
- arch = x86_64
+ install = nagios-nrpe-plugin.install
+ arch = any
license = GPL
depends = nagios
- source = http://downloads.sourceforge.net/nagios/nrpe-2.14.tar.gz
- md5sums = 105857720e21674083a6d6be99e102c7
+ source = http://downloads.sourceforge.net/nagios/nrpe-2.15.tar.gz
+ md5sums = 3921ddc598312983f604541784b35a50
pkgname = nagios-nrpe-plugin
diff --git a/.gitignore b/.gitignore
index b73dc06cbe3e..3b97a57bf96e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,5 @@ pkg/
src/
nrpe-*.tar.gz
nagios-nrpe-plugin-*.src.tar.gz
-nagios-nrpe-plugin-*.pkg.tar.*
+nagios-nrpe-plugin-*.pkg.tar*
*.swp
diff --git a/PKGBUILD b/PKGBUILD
index d85371ca28f5..e50f28b226f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Maintainer: Mark Grimes <mgrimes at peculier dot com>
-# https://github.com/mvgrimes/aur-nagios-npre-plugin
# Contributor: Idares <idares@seznam.cz>
+# https://github.com/mvgrimes/aur-nagios-npre-plugin
pkgname=nagios-nrpe-plugin
-pkgver=2.14
-pkgrel=1
+pkgver=2.15
+pkgrel=3
pkgdesc="The Nagios NRPE server side plugin."
license=('GPL')
-arch=('i686' 'x86_64')
+arch=('any')
url="http://www.nagios.org"
source=("http://downloads.sourceforge.net/nagios/nrpe-${pkgver}.tar.gz")
-md5sums=('105857720e21674083a6d6be99e102c7')
+md5sums=('3921ddc598312983f604541784b35a50')
depends=(nagios)
+install=nagios-nrpe-plugin.install
build() {
cd ${srcdir}/nrpe-${pkgver}
- ./configure --prefix=/usr/share/nagios \
+ ./configure --prefix=/usr/lib/monitoring-plugins \
--with-nagios-user=nagios --with-nagios-group=nagios || return 1
make || return 1
}
package() {
cd ${srcdir}/nrpe-${pkgver}
- make prefix=${pkgdir}/usr/share/nagios install-plugin || return 1
+ make prefix=${pkgdir}/usr/lib/monitoring-plugins install-plugin || return 1
}
diff --git a/README b/README
index 9fbe2bca5038..d08c4c026f05 100644
--- a/README
+++ b/README
@@ -9,4 +9,4 @@ To updated version:
- Run `makepkg -g` and copy MD5 sum to PKGBUILD
- Run `makepkg`
- Run `makepkg --source` and upload the nagios-nrpe-plugin-*.src.tar.gz file.
-- Commit to git and tag
+- Commit to git and tag v2.14-1
diff --git a/nagios-nrpe-plugin.install b/nagios-nrpe-plugin.install
new file mode 100644
index 000000000000..40975dbc06b4
--- /dev/null
+++ b/nagios-nrpe-plugin.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "check_nrpe has been moved to /usr/lib/monitoring-plugins to"
+ echo "be consistent with the change from nagios-plugins to"
+ echo "monitoring-plugins. You may need to tell nagios where the"
+ echo "plugins are located, or symlink /usr/share/nagios/libexec to"
+ echo "/usr/lib/monitoring-plugins."
+}
+
+post_upgrade() {
+ post_install $1
+}