summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authort-onoz2018-06-15 10:00:13 +0900
committert-onoz2018-06-15 10:00:13 +0900
commitaab7b40258fdc19792fe38c0cf0747ce5d6e9158 (patch)
tree4d44e4c44bec6bc99ce505ec4957518f25c6ee7e
downloadaur-aab7b40258fdc19792fe38c0cf0747ce5d6e9158.tar.gz
Initial upload: nagome-electron 1.0.0-1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
-rw-r--r--nagome-electron.desktop13
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41ee379643d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = nagome-electron
+ pkgdesc = NicoNama comment viewer
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/diginatu/nagome-electron
+ arch = x86_64
+ license = MIT
+ depends = gtk2
+ depends = libxss
+ depends = libxtst
+ depends = gconf
+ depends = alsa-lib
+ depends = nss
+ source = https://github.com/diginatu/nagome-electron/releases/download/v1.0.0/nagome-electron-1.0.0.tar.xz
+ source = https://raw.githubusercontent.com/diginatu/nagome-electron/master/images/icon.png
+ source = https://raw.githubusercontent.com/diginatu/nagome-electron/master/LICENSE
+ source = nagome-electron.desktop
+ md5sums = 6868eb158d107d7be05c13f120057ea8
+ md5sums = dcf67353e015d7489f5b771e0c9e8ffe
+ md5sums = 726fff92b313b3d527d0075756e34892
+ md5sums = 1db0c25395efc437035a1c087d308268
+
+pkgname = nagome-electron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..899808a79dff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=nagome-electron
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="NicoNama comment viewer"
+arch=('x86_64')
+url="https://github.com/diginatu/nagome-electron"
+license=('MIT')
+depends=(gtk2 libxss libxtst gconf alsa-lib nss)
+source=("https://github.com/diginatu/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz"
+"https://raw.githubusercontent.com/diginatu/$pkgname/master/images/icon.png"
+"https://raw.githubusercontent.com/diginatu/nagome-electron/master/LICENSE"
+"$pkgname.desktop")
+md5sums=('6868eb158d107d7be05c13f120057ea8'
+ 'dcf67353e015d7489f5b771e0c9e8ffe'
+ '726fff92b313b3d527d0075756e34892'
+ '1db0c25395efc437035a1c087d308268')
+
+package() {
+ mkdir -p "$pkgdir/opt/" "$pkgdir/usr/bin"
+ cp -R "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/$pkgname"
+
+ ln -s "/opt/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/icon.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/nagome-electron.desktop b/nagome-electron.desktop
new file mode 100644
index 000000000000..d8a6b091ff70
--- /dev/null
+++ b/nagome-electron.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Nagome-electron
+Comment=Cross-platform "Nico Nama" comment viewer
+Exec=nagome-electron
+NoDisplay=false
+Terminal=0
+TerminalOptions=
+Type=Application
+Icon=nagome-electron
+Categories=Network;
+StartupNotify=true
+X-KDE-SubstituteUID=false
+X-KDE-Username=