summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornavigaid2019-09-19 21:12:48 +0800
committernavigaid2019-09-19 21:12:53 +0800
commit687beb6b473e84bb095797f438670bbe2a0f3820 (patch)
treefd7e3223738579e995410129c9dec9e1b0925dcd
parent6c5ffb1254bc61ade8e1d1390eb53578336c883d (diff)
downloadaur-687beb6b473e84bb095797f438670bbe2a0f3820.tar.gz
makedepends: add unzip and python2 as suggested by mystique
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xbuild_arm.sh1
3 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7fd02ad6a57..585a8ec5c122 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,8 @@ pkgbase = naiveproxy
makedepends = git
makedepends = ninja
makedepends = cmake
+ makedepends = unzip
+ makedepends = python2
depends = nspr
depends = nss
optdepends = ccache: Speed up compilation
diff --git a/PKGBUILD b/PKGBUILD
index 812abcb07adc..f023a81e4e8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('x86_64')
url='https://github.com/klzgrad/naiveproxy'
license=('BSD')
depends=('nspr' 'nss')
-makedepends=('git' 'ninja' 'cmake')
+makedepends=('git' 'ninja' 'cmake' 'unzip' 'python2')
source=("${pkgname}.tar.gz::https://github.com/btwiuse/naiveproxy/archive/v${pkgver}-${pkgrel}.tar.gz")
md5sums=('f3b1ba2190b0564cc7e38aa6a2147676')
optdepends=("ccache: Speed up compilation")
diff --git a/build_arm.sh b/build_arm.sh
index 2e5ef3245f2e..f366bf6e8008 100755
--- a/build_arm.sh
+++ b/build_arm.sh
@@ -32,6 +32,7 @@ elif [ -f "$HOME"/.cargo/bin/sccache* ]; then
fi
flags="$flags"'
+ use_custom_libcxx=false
target_cpu="arm"
is_clang=true
linux_use_bundled_binutils=false