summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzu1k2022-06-30 18:39:51 +0800
committerzu1k2022-06-30 18:39:51 +0800
commit59b0b8f1369a50d55465ee2f846e91974d1faf77 (patch)
treebf7e89e969402a9b4135cfd84c5afccba7b00613
downloadaur-59b0b8f1369a50d55465ee2f846e91974d1faf77.tar.gz
init: version 0.4.5
Signed-off-by: zu1k <i@zu1k.com>
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD32
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef48debf7464
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = nali-go-bin
+ pkgdesc = An offline tool for querying IP geographic information and CDN provider. (Pre-compiled)
+ pkgver = 0.4.5
+ pkgrel = 1
+ url = https://github.com/zu1k/nali
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = MIT
+ provides = nali
+ conflicts = nali
+ source_i686 = https://github.com/zu1k/nali/releases/download/v0.4.5/nali-linux-386-v0.4.5.gz
+ sha256sums_i686 = a9977e18853d0c9bf0f9f06acaa55714e99a234ed10b75a3e9523570b6aad5f1
+ source_x86_64 = https://github.com/zu1k/nali/releases/download/v0.4.5/nali-linux-amd64-v0.4.5.gz
+ sha256sums_x86_64 = 337465ec14e6f5a122f45fcece95c9445817cb7bb9bf4934cae84203ecf71162
+ source_arm = https://github.com/zu1k/nali/releases/download/v0.4.5/nali-linux-armv5-v0.4.5.gz
+ sha256sums_arm = ef222f56d635ad486c8dc9a9b375dcb5d5353cbac9c0f77f524bacc4cdb05259
+ source_armv7h = https://github.com/zu1k/nali/releases/download/v0.4.5/nali-linux-armv7-v0.4.5.gz
+ sha256sums_armv7h = 29fd83a72e6d6a49ea15577c4f1bd8e2663a6b45ea8ffcf2b42505dce6a18702
+ source_armv6h = https://github.com/zu1k/nali/releases/download/v0.4.5/nali-linux-armv6-v0.4.5.gz
+ sha256sums_armv6h = 174e6bc7e6be247637f0519288e6b82fbd6d6f2a37e4edbd686cb2934a2f6e79
+ source_aarch64 = https://github.com/zu1k/nali/releases/download/v0.4.5/nali-linux-armv8-v0.4.5.gz
+ sha256sums_aarch64 = a2024f86a272c083604e2257be1ffc38553506dc54dd49fbc5476ed0356173cd
+
+pkgname = nali-go-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2490fde13f04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: zu1k <i@zu1k.com>
+
+pkgname=nali-go-bin
+_pkgname=nali
+pkgver=0.4.5
+pkgrel=1
+pkgdesc='An offline tool for querying IP geographic information and CDN provider. (Pre-compiled)'
+arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/zu1k/nali"
+license=('MIT')
+provides=('nali')
+conflicts=('nali')
+
+source_i686=("https://github.com/zu1k/nali/releases/download/v${pkgver}/$_pkgname-linux-386-v$pkgver.gz")
+source_x86_64=("https://github.com/zu1k/nali/releases/download/v${pkgver}/$_pkgname-linux-amd64-v$pkgver.gz")
+source_aarch64=("https://github.com/zu1k/nali/releases/download/v${pkgver}/$_pkgname-linux-armv8-v$pkgver.gz")
+source_armv6h=("https://github.com/zu1k/nali/releases/download/v${pkgver}/$_pkgname-linux-armv6-v$pkgver.gz")
+source_armv7h=("https://github.com/zu1k/nali/releases/download/v${pkgver}/$_pkgname-linux-armv7-v$pkgver.gz")
+source_arm=("https://github.com/zu1k/nali/releases/download/v${pkgver}/$_pkgname-linux-armv5-v$pkgver.gz")
+
+sha256sums_i686=('a9977e18853d0c9bf0f9f06acaa55714e99a234ed10b75a3e9523570b6aad5f1')
+sha256sums_x86_64=('337465ec14e6f5a122f45fcece95c9445817cb7bb9bf4934cae84203ecf71162')
+sha256sums_arm=('ef222f56d635ad486c8dc9a9b375dcb5d5353cbac9c0f77f524bacc4cdb05259')
+sha256sums_armv7h=('29fd83a72e6d6a49ea15577c4f1bd8e2663a6b45ea8ffcf2b42505dce6a18702')
+sha256sums_armv6h=('174e6bc7e6be247637f0519288e6b82fbd6d6f2a37e4edbd686cb2934a2f6e79')
+sha256sums_aarch64=('a2024f86a272c083604e2257be1ffc38553506dc54dd49fbc5476ed0356173cd')
+
+
+package() {
+ cd "$srcdir"
+ install -Dm755 $_pkgname-linux-*-v$pkgver "$pkgdir"/usr/bin/$_pkgname
+}