summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2016-08-03 10:23:00 -0400
committerSergio Correia2016-08-03 10:23:00 -0400
commit56c0103d108521112198080868b57584998c2a47 (patch)
tree0c7ed3dc3739f51ab2dc17a3d8e97d5a891e046e
parent54a870c3e8aea758558e91fb9ff4aad4d2870b24 (diff)
downloadaur-56c0103d108521112198080868b57584998c2a47.tar.gz
Fix compilation with gcc 6.x
Bump to 1.15-5.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--nam-1.15-gcc61.patch381
3 files changed, 393 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 110041303c21..14f27dc2be68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
+# Generated by makepkg 5.0.1
+# Wed Aug 3 14:22:23 UTC 2016
pkgbase = nam
pkgdesc = Tcl/TK based animation tool for viewing network simulation traces and real world packet traces
pkgver = 1.15
- pkgrel = 4
+ pkgrel = 5
url = http://www.isi.edu/nsnam/nam/
arch = i686
arch = x86_64
license = GPL
makedepends = tclcl
- depends = gcc-libs
depends = otcl
- depends = sh
source = http://downloads.sourceforge.net/sourceforge/nsnam/nam-1/1.15/nam-src-1.15.tar.gz
source = nam-1.15-tcl86.patch
+ source = nam-1.15-gcc61.patch
sha256sums = 12ed547b3a5f8903890889d40cfea4d9bd66bb9ba6be99a0c753a9763cad8882
sha256sums = 2766040c6c367a03efa43e81cbe178150fad6f4ee0b2b6d0b87292cb7c0bfe0b
+ sha256sums = b0ce4fb0b1fa6fe91ed26fd5daabede4521362f781364edcea4d7bff7d64472c
pkgname = nam
diff --git a/PKGBUILD b/PKGBUILD
index 59ed1b00ad5a..bd4150b9c520 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,24 @@
pkgname=nam
pkgver=1.15
-pkgrel=4
+pkgrel=5
pkgdesc="Tcl/TK based animation tool for viewing network simulation traces and real world packet traces"
url="http://www.isi.edu/nsnam/nam/"
license=('GPL')
arch=('i686' 'x86_64')
-depends=('gcc-libs' 'otcl' 'sh')
+depends=('otcl')
makedepends=('tclcl')
source=(http://downloads.sourceforge.net/sourceforge/nsnam/nam-1/"${pkgver}"/nam-src-"${pkgver}".tar.gz
- nam-1.15-tcl86.patch)
+ nam-1.15-tcl86.patch
+ nam-1.15-gcc61.patch)
sha256sums=('12ed547b3a5f8903890889d40cfea4d9bd66bb9ba6be99a0c753a9763cad8882'
- '2766040c6c367a03efa43e81cbe178150fad6f4ee0b2b6d0b87292cb7c0bfe0b')
+ '2766040c6c367a03efa43e81cbe178150fad6f4ee0b2b6d0b87292cb7c0bfe0b'
+ 'b0ce4fb0b1fa6fe91ed26fd5daabede4521362f781364edcea4d7bff7d64472c')
prepare() {
cd "${srcdir}"/"${pkgname}"-"${pkgver}"
patch -uNp1 -i ../nam-1.15-tcl86.patch
+ patch -uNp1 -i ../nam-1.15-gcc61.patch
}
build() {
diff --git a/nam-1.15-gcc61.patch b/nam-1.15-gcc61.patch
new file mode 100644
index 000000000000..4f0ea570bd7d
--- /dev/null
+++ b/nam-1.15-gcc61.patch
@@ -0,0 +1,381 @@
+diff --git a/bitmap/addagentlink.xbm b/bitmap/addagentlink.xbm
+index 24fb84b..e7c2105 100644
+--- a/bitmap/addagentlink.xbm
++++ b/bitmap/addagentlink.xbm
+@@ -1,6 +1,6 @@
+ #define addagentlink_width 21
+ #define addagentlink_height 16
+-static char addagentlink_bits[] = {
++static unsigned char addagentlink_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+ 0x00, 0x00, 0x00, 0x0f, 0x00, 0x1e, 0xf9, 0xff, 0x13, 0xf9, 0xff, 0x13,
+ 0x0f, 0x00, 0x1e, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+diff --git a/bitmap/addlink.xbm b/bitmap/addlink.xbm
+index 10729a6..bee1dff 100644
+--- a/bitmap/addlink.xbm
++++ b/bitmap/addlink.xbm
+@@ -1,6 +1,6 @@
+ #define addlink_width 21
+ #define addlink_height 16
+-static char addlink_bits[] = {
++static unsigned char addlink_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+ 0x00, 0x00, 0x00, 0x07, 0x00, 0x1c, 0xff, 0xff, 0x1f, 0xff, 0xff, 0x1f,
+ 0x07, 0x00, 0x1c, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+diff --git a/bitmap/addnode.xbm b/bitmap/addnode.xbm
+index 535216f..7859e56 100644
+--- a/bitmap/addnode.xbm
++++ b/bitmap/addnode.xbm
+@@ -1,6 +1,6 @@
+ #define addnode_width 21
+ #define addnode_height 16
+-static char addnode_bits[] = {
++static unsigned char addnode_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x0e, 0x00, 0x80, 0x31, 0x00, 0x60, 0xc0, 0x00,
+ 0x20, 0x84, 0x00, 0x10, 0x00, 0x01, 0x10, 0x04, 0x01, 0x08, 0x04, 0x02,
+ 0x08, 0x04, 0x02, 0x08, 0x04, 0x02, 0x10, 0x04, 0x01, 0x10, 0x04, 0x01,
+diff --git a/bitmap/back.xbm b/bitmap/back.xbm
+index 9c97acb..0136976 100644
+--- a/bitmap/back.xbm
++++ b/bitmap/back.xbm
+@@ -1,6 +1,6 @@
+ #define back_width 20
+ #define back_height 13
+-static char back_bits[] = {
++static unsigned char back_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0xc0, 0x00, 0x00, 0xf0, 0x00, 0x00, 0xfc, 0x00,
+ 0x00, 0xff, 0x00, 0xc0, 0xff, 0x00, 0xf0, 0xff, 0x00, 0xc0, 0xff, 0x00,
+ 0x00, 0xff, 0x00, 0x00, 0xfc, 0x00, 0x00, 0xf0, 0x00, 0x00, 0xc0, 0x00,
+diff --git a/bitmap/cut.xbm b/bitmap/cut.xbm
+index c8ebb92..bf3c7d7 100644
+--- a/bitmap/cut.xbm
++++ b/bitmap/cut.xbm
+@@ -1,6 +1,6 @@
+ #define cut_width 21
+ #define cut_height 16
+-static char cut_bits[] = {
++static unsigned char cut_bits[] = {
+ 0x08, 0x00, 0x01, 0x08, 0x00, 0x01, 0x08, 0x00, 0x01, 0x10, 0xc0, 0x00,
+ 0x10, 0xc0, 0x00, 0x60, 0x20, 0x00, 0x60, 0x20, 0x00, 0x80, 0x10, 0x00,
+ 0x80, 0x10, 0x00, 0x00, 0x09, 0x00, 0x00, 0x09, 0x00, 0x00, 0x06, 0x00,
+diff --git a/bitmap/delete.xbm b/bitmap/delete.xbm
+index eab2e47..c3aa977 100644
+--- a/bitmap/delete.xbm
++++ b/bitmap/delete.xbm
+@@ -2,7 +2,7 @@
+ #define delete_height 16
+ #define delete_x_hot 10
+ #define delete_y_hot 8
+-static char delete_bits[] = {
++static unsigned char delete_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x0e, 0x00, 0x80, 0x31, 0x00, 0x60, 0xc0, 0x00,
+ 0x20, 0xe0, 0x00, 0x10, 0x70, 0x01, 0x10, 0x38, 0x01, 0x08, 0x1c, 0x02,
+ 0x08, 0x0e, 0x02, 0x08, 0x07, 0x02, 0x90, 0x03, 0x01, 0xd0, 0x01, 0x01,
+diff --git a/bitmap/edit.xbm b/bitmap/edit.xbm
+index 07e4f7c..73e9096 100644
+--- a/bitmap/edit.xbm
++++ b/bitmap/edit.xbm
+@@ -2,7 +2,7 @@
+ #define edit_height 17
+ #define edit_x_hot 0
+ #define edit_y_hot 0
+-static char edit_bits[] = {
++static unsigned char edit_bits[] = {
+ 0x07, 0xc0, 0xff, 0xff, 0xff, 0xff, 0x07, 0xe0, 0xff, 0x02, 0x10, 0xfe,
+ 0x02, 0x18, 0xfe, 0x02, 0x0c, 0xfe, 0x02, 0x04, 0xfe, 0x82, 0x03, 0xfe,
+ 0x82, 0x03, 0xfe, 0x82, 0x03, 0xfe, 0x02, 0x04, 0xfe, 0x02, 0x08, 0xfe,
+diff --git a/bitmap/eject.xbm b/bitmap/eject.xbm
+index d1c37e0..c63489a 100644
+--- a/bitmap/eject.xbm
++++ b/bitmap/eject.xbm
+@@ -1,6 +1,6 @@
+ #define eject_width 20
+ #define eject_height 13
+-static char eject_bits[] = {
++static unsigned char eject_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x06, 0x00, 0x00, 0x0f, 0x00, 0x80, 0x1f, 0x00,
+ 0xc0, 0x3f, 0x00, 0xe0, 0x7f, 0x00, 0x00, 0x00, 0x00, 0x00, 0x06, 0x00,
+ 0x00, 0x0f, 0x00, 0x80, 0x1f, 0x00, 0xc0, 0x3f, 0x00, 0xe0, 0x7f, 0x00,
+diff --git a/bitmap/ff.xbm b/bitmap/ff.xbm
+index 51614f3..0db9d79 100644
+--- a/bitmap/ff.xbm
++++ b/bitmap/ff.xbm
+@@ -1,6 +1,6 @@
+ #define ff_width 20
+ #define ff_height 13
+-static char ff_bits[] = {
++static unsigned char ff_bits[] = {
+ 0x00, 0x00, 0x00, 0x08, 0x08, 0x00, 0x18, 0x18, 0x00, 0x38, 0x38, 0x00,
+ 0x78, 0x78, 0x00, 0xf8, 0xf8, 0x00, 0xf8, 0xf9, 0x01, 0xf8, 0xf8, 0x00,
+ 0x78, 0x78, 0x00, 0x38, 0x38, 0x00, 0x18, 0x18, 0x00, 0x08, 0x08, 0x00,
+diff --git a/bitmap/mark1.xbm b/bitmap/mark1.xbm
+index c049d44..307becd 100644
+--- a/bitmap/mark1.xbm
++++ b/bitmap/mark1.xbm
+@@ -2,5 +2,5 @@
+ #define mark1_height 8
+ #define mark1_x_hot 3
+ #define mark1_y_hot 3
+-static char mark1_bits[] = {
++static unsigned char mark1_bits[] = {
+ 0x00, 0x00, 0x1c, 0x1c, 0x1c, 0x00, 0x00, 0x00};
+diff --git a/bitmap/mark2.xbm b/bitmap/mark2.xbm
+index 25137a4..f05e2dd 100644
+--- a/bitmap/mark2.xbm
++++ b/bitmap/mark2.xbm
+@@ -2,5 +2,5 @@
+ #define mark2_height 8
+ #define mark2_x_hot 3
+ #define mark2_y_hot 3
+-static char mark2_bits[] = {
++static unsigned char mark2_bits[] = {
+ 0x00, 0x3e, 0x22, 0x22, 0x22, 0x3e, 0x00, 0x00};
+diff --git a/bitmap/mark3.xbm b/bitmap/mark3.xbm
+index d1d9273..616ced1 100644
+--- a/bitmap/mark3.xbm
++++ b/bitmap/mark3.xbm
+@@ -2,5 +2,5 @@
+ #define mark3_height 8
+ #define mark3_x_hot 3
+ #define mark3_y_hot 3
+-static char mark3_bits[] = {
++static unsigned char mark3_bits[] = {
+ 0x00, 0x1c, 0x36, 0x22, 0x36, 0x1c, 0x00, 0x00};
+diff --git a/bitmap/mark4.xbm b/bitmap/mark4.xbm
+index 2136936..dfe0b45 100644
+--- a/bitmap/mark4.xbm
++++ b/bitmap/mark4.xbm
+@@ -2,5 +2,5 @@
+ #define mark4_height 8
+ #define mark4_x_hot 3
+ #define mark4_y_hot 3
+-static char mark4_bits[] = {
++static unsigned char mark4_bits[] = {
+ 0x00, 0x22, 0x14, 0x08, 0x14, 0x22, 0x00, 0x00};
+diff --git a/bitmap/mark5.xbm b/bitmap/mark5.xbm
+index 1200f07..637dccc 100644
+--- a/bitmap/mark5.xbm
++++ b/bitmap/mark5.xbm
+@@ -2,5 +2,5 @@
+ #define mark5_height 8
+ #define mark5_x_hot 3
+ #define mark5_y_hot 3
+-static char mark5_bits[] = {
++static unsigned char mark5_bits[] = {
+ 0x00, 0x08, 0x14, 0x22, 0x14, 0x08, 0x00, 0x00};
+diff --git a/bitmap/mark6.xbm b/bitmap/mark6.xbm
+index 41393ea..e998221 100644
+--- a/bitmap/mark6.xbm
++++ b/bitmap/mark6.xbm
+@@ -2,5 +2,5 @@
+ #define mark6_height 8
+ #define mark6_x_hot 3
+ #define mark6_y_hot 3
+-static char mark6_bits[] = {
++static unsigned char mark6_bits[] = {
+ 0x00, 0x1c, 0x14, 0x1c, 0x14, 0x1c, 0x00, 0x00};
+diff --git a/bitmap/mark7.xbm b/bitmap/mark7.xbm
+index 8467824..fbb5151 100644
+--- a/bitmap/mark7.xbm
++++ b/bitmap/mark7.xbm
+@@ -2,5 +2,5 @@
+ #define mark7_height 8
+ #define mark7_x_hot 3
+ #define mark7_y_hot 3
+-static char mark7_bits[] = {
++static unsigned char mark7_bits[] = {
+ 0x00, 0x1c, 0x2a, 0x36, 0x2a, 0x1c, 0x00, 0x00};
+diff --git a/bitmap/mark8.xbm b/bitmap/mark8.xbm
+index c1b98f9..1901f43 100644
+--- a/bitmap/mark8.xbm
++++ b/bitmap/mark8.xbm
+@@ -2,5 +2,5 @@
+ #define mark8_height 8
+ #define mark8_x_hot 3
+ #define mark8_y_hot 3
+-static char mark8_bits[] = {
++static unsigned char mark8_bits[] = {
+ 0x00, 0x3e, 0x1c, 0x08, 0x1c, 0x3e, 0x00, 0x00};
+diff --git a/bitmap/monitors.xbm b/bitmap/monitors.xbm
+index 3f709b4..7edbf22 100644
+--- a/bitmap/monitors.xbm
++++ b/bitmap/monitors.xbm
+@@ -1,6 +1,6 @@
+ #define monitors_width 16
+ #define monitors_height 75
+-static char monitors_bits[] = {
++static unsigned char monitors_bits[] = {
+ 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,
+ 0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x00,0x40,0x06,
+ 0x60,0x0f,0x60,0x0f,0xe0,0x0d,0xe0,0x0d,0xc0,0x04,0x60,0x00,0x60,0x00,0xe0,
+diff --git a/bitmap/netedit.xbm b/bitmap/netedit.xbm
+index 8cee910..2affb31 100644
+--- a/bitmap/netedit.xbm
++++ b/bitmap/netedit.xbm
+@@ -2,7 +2,7 @@
+ #define netedit_height 25
+ #define netedit_x_hot 0
+ #define netedit_y_hot 0
+-static char netedit_bits[] = {
++static unsigned char netedit_bits[] = {
+ 0x00, 0x00, 0xfe, 0x00, 0x00, 0xfe, 0x00, 0x00, 0xfe, 0x00, 0x00, 0xfe,
+ 0x78, 0x3c, 0xfe, 0x08, 0x44, 0xfe, 0x38, 0x44, 0xfe, 0x08, 0x44, 0xfe,
+ 0x08, 0x44, 0xfe, 0x78, 0x3c, 0xfe, 0x00, 0x00, 0xfe, 0x00, 0x00, 0xfe,
+diff --git a/bitmap/netview.xbm b/bitmap/netview.xbm
+index d24ec5e..2e35621 100644
+--- a/bitmap/netview.xbm
++++ b/bitmap/netview.xbm
+@@ -2,7 +2,7 @@
+ #define netview_height 25
+ #define netview_x_hot 0
+ #define netview_y_hot 0
+-static char netview_bits[] = {
++static unsigned char netview_bits[] = {
+ 0x00, 0x00, 0xf8, 0x00, 0x00, 0xf8, 0x00, 0x00, 0xf8, 0x00, 0x00, 0xf8,
+ 0x48, 0x10, 0xf8, 0x48, 0x10, 0xf8, 0x48, 0x10, 0xf8, 0x48, 0x10, 0xf8,
+ 0x28, 0x10, 0xf8, 0x10, 0x10, 0xf8, 0x00, 0x00, 0xf8, 0x00, 0x00, 0xf8,
+diff --git a/bitmap/nodedown.xbm b/bitmap/nodedown.xbm
+index 0595e53..08fd681 100644
+--- a/bitmap/nodedown.xbm
++++ b/bitmap/nodedown.xbm
+@@ -2,7 +2,7 @@
+ #define nodedown_height 16
+ #define nodedown_x_hot 0
+ #define nodedown_y_hot 0
+-static char nodedown_bits[] = {
++static unsigned char nodedown_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0xc0, 0x01, 0x20, 0x02,
+ 0x10, 0x04, 0x10, 0x04, 0x10, 0x04, 0x20, 0x02, 0xc0, 0x01, 0x00, 0x00,
+ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00};
+diff --git a/bitmap/nodeup.xbm b/bitmap/nodeup.xbm
+index 3965d81..6b0caac 100644
+--- a/bitmap/nodeup.xbm
++++ b/bitmap/nodeup.xbm
+@@ -2,7 +2,7 @@
+ #define nodeup_height 16
+ #define nodeup_x_hot 0
+ #define nodeup_y_hot 0
+-static char nodeup_bits[] = {
++static unsigned char nodeup_bits[] = {
+ 0x00, 0x00, 0xe0, 0x01, 0x18, 0x06, 0x04, 0x08, 0x04, 0x08, 0x02, 0x10,
+ 0x02, 0x10, 0x02, 0x10, 0x02, 0x10, 0x04, 0x08, 0x04, 0x08, 0x18, 0x06,
+ 0xe0, 0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00};
+diff --git a/bitmap/play.xbm b/bitmap/play.xbm
+index ea93a8a..de1628e 100644
+--- a/bitmap/play.xbm
++++ b/bitmap/play.xbm
+@@ -1,6 +1,6 @@
+ #define play_width 20
+ #define play_height 13
+-static char play_bits[] = {
++static unsigned char play_bits[] = {
+ 0x00, 0x00, 0x00, 0x30, 0x00, 0x00, 0xf0, 0x00, 0x00, 0xf0, 0x03, 0x00,
+ 0xf0, 0x0f, 0x00, 0xf0, 0x3f, 0x00, 0xf0, 0xff, 0x00, 0xf0, 0x3f, 0x00,
+ 0xf0, 0x0f, 0x00, 0xf0, 0x03, 0x00, 0xf0, 0x00, 0x00, 0x30, 0x00, 0x00,
+diff --git a/bitmap/pullright.xbm b/bitmap/pullright.xbm
+index cc61fd8..b8e26ad 100644
+--- a/bitmap/pullright.xbm
++++ b/bitmap/pullright.xbm
+@@ -1,6 +1,6 @@
+ #define pullright_width 14
+ #define pullright_height 28
+-static char pullright_bits[] = {
++static unsigned char pullright_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x04, 0x00, 0x0c, 0x00, 0x1c, 0x00,
+ 0x3c, 0x00, 0x7c, 0x00, 0xec, 0x00, 0xcc, 0x01, 0x8c, 0x03, 0x0c, 0x07,
+ 0x0c, 0x0e, 0x0c, 0x1c, 0x0c, 0x0e, 0x0c, 0x07, 0x8c, 0x03, 0xcc, 0x01,
+diff --git a/bitmap/rew.xbm b/bitmap/rew.xbm
+index ddc07ad..f619e60 100644
+--- a/bitmap/rew.xbm
++++ b/bitmap/rew.xbm
+@@ -1,6 +1,6 @@
+ #define rew_width 20
+ #define rew_height 13
+-static char rew_bits[] = {
++static unsigned char rew_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x01, 0x01, 0x80, 0x81, 0x01, 0xc0, 0xc1, 0x01,
+ 0xe0, 0xe1, 0x01, 0xf0, 0xf1, 0x01, 0xf8, 0xf9, 0x01, 0xf0, 0xf1, 0x01,
+ 0xe0, 0xe1, 0x01, 0xc0, 0xc1, 0x01, 0x80, 0x81, 0x01, 0x00, 0x01, 0x01,
+diff --git a/bitmap/rewind.xbm b/bitmap/rewind.xbm
+index 929e7a0..d466abf 100644
+--- a/bitmap/rewind.xbm
++++ b/bitmap/rewind.xbm
+@@ -1,5 +1,5 @@
+ #define rewind_width 15
+ #define rewind_height 12
+-static char rewind_bits[] = {
++static unsigned char rewind_bits[] = {
+ 0x00, 0x00, 0x40, 0x10, 0x60, 0x18, 0x70, 0x1c, 0x78, 0x1e, 0x7c, 0x1f,
+ 0x7c, 0x1f, 0x78, 0x1e, 0x70, 0x1c, 0x60, 0x18, 0x40, 0x10, 0x00, 0x00};
+diff --git a/bitmap/select.xbm b/bitmap/select.xbm
+index 54b79c0..99d7057 100644
+--- a/bitmap/select.xbm
++++ b/bitmap/select.xbm
+@@ -1,6 +1,6 @@
+ #define select_width 21
+ #define select_height 16
+-static char select_bits[] = {
++static unsigned char select_bits[] = {
+ 0x03, 0x00, 0x00, 0x0f, 0x00, 0x00, 0x7e, 0x00, 0x00, 0xfc, 0x01, 0x00,
+ 0xfc, 0x0f, 0x00, 0xf8, 0x3f, 0x00, 0xf8, 0x1f, 0x00, 0xf0, 0x0f, 0x00,
+ 0xe0, 0x0f, 0x00, 0xe0, 0x13, 0x00, 0xc0, 0x20, 0x00, 0x40, 0xc0, 0x00,
+diff --git a/bitmap/stop.xbm b/bitmap/stop.xbm
+index 363dc20..530d836 100644
+--- a/bitmap/stop.xbm
++++ b/bitmap/stop.xbm
+@@ -1,6 +1,6 @@
+ #define stop_width 20
+ #define stop_height 13
+-static char stop_bits[] = {
++static unsigned char stop_bits[] = {
+ 0x00, 0x00, 0x00, 0xe0, 0x7f, 0x00, 0xe0, 0x7f, 0x00, 0xe0, 0x7f, 0x00,
+ 0xe0, 0x7f, 0x00, 0xe0, 0x7f, 0x00, 0xe0, 0x7f, 0x00, 0xe0, 0x7f, 0x00,
+ 0xe0, 0x7f, 0x00, 0xe0, 0x7f, 0x00, 0xe0, 0x7f, 0x00, 0xe0, 0x7f, 0x00,
+diff --git a/bitmap/time.xbm b/bitmap/time.xbm
+index 89b7b16..f6ccaf7 100644
+--- a/bitmap/time.xbm
++++ b/bitmap/time.xbm
+@@ -1,6 +1,6 @@
+ #define time_width 30
+ #define time_height 10
+-static char time_bits[] = {
++static unsigned char time_bits[] = {
+ 0xff, 0x5f, 0xff, 0x3f, 0x01, 0x40, 0x00, 0x20, 0x7d, 0x47, 0x44, 0x2f,
+ 0x11, 0xe2, 0x6c, 0x21, 0x11, 0xe2, 0x54, 0x23, 0x11, 0xe2, 0x44, 0x21,
+ 0x11, 0xe2, 0x44, 0x21, 0x11, 0xf7, 0x45, 0x2f, 0x01, 0xf0, 0x01, 0x20,
+diff --git a/bitmap/updir.xbm b/bitmap/updir.xbm
+index ac31d30..89637d0 100644
+--- a/bitmap/updir.xbm
++++ b/bitmap/updir.xbm
+@@ -1,6 +1,6 @@
+ #define updir_width 28
+ #define updir_height 16
+-static char updir_bits[] = {
++static unsigned char updir_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x80, 0x1f, 0x00, 0x00, 0x40, 0x20, 0x00, 0x00,
+ 0x20, 0x40, 0x00, 0x00, 0xf0, 0xff, 0xff, 0x01, 0x10, 0x00, 0x00, 0x01,
+ 0x10, 0x02, 0x00, 0x01, 0x10, 0x07, 0x00, 0x01, 0x90, 0x0f, 0x00, 0x01,
+diff --git a/bitmap/zoomin.xbm b/bitmap/zoomin.xbm
+index d257938..2a6366b 100644
+--- a/bitmap/zoomin.xbm
++++ b/bitmap/zoomin.xbm
+@@ -1,6 +1,6 @@
+ #define zoomin_width 21
+ #define zoomin_height 16
+-static char zoomin_bits[] = {
++static unsigned char zoomin_bits[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x04, 0x00, 0x00, 0x1b, 0x00, 0xc0, 0x60, 0x00,
+ 0x30, 0x80, 0x01, 0x0c, 0x00, 0x06, 0xff, 0xe0, 0x1f, 0x41, 0x40, 0x10,
+ 0x21, 0x80, 0x10, 0x3f, 0x80, 0x1f, 0xf0, 0xff, 0x01, 0x10, 0x00, 0x01,
+diff --git a/bitmap/zoomout.xbm b/bitmap/zoomout.xbm
+index 635ba36..00f5f52 100644
+--- a/bitmap/zoomout.xbm
++++ b/bitmap/zoomout.xbm
+@@ -1,6 +1,6 @@
+ #define zoomout_width 21
+ #define zoomout_height 16
+-static char zoomout_bits[] = {
++static unsigned char zoomout_bits[] = {
+ 0x00, 0x00, 0x00, 0xf0, 0xff, 0x01, 0x30, 0x80, 0x01, 0x50, 0x40, 0x01,
+ 0xa0, 0xa0, 0x00, 0xff, 0xe0, 0x1f, 0x07, 0x00, 0x1c, 0x19, 0x00, 0x13,
+ 0x61, 0xc0, 0x10, 0x81, 0x31, 0x10, 0x06, 0x0e, 0x0c, 0x18, 0x04, 0x03,