summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBigRush2018-08-04 17:36:42 +0300
committerBigRush2018-08-04 17:36:42 +0300
commitb8114c0f71d7ad99eeb7635fbeac282082e45705 (patch)
tree7bd6dd499aa5faa2e596171787f266a1ce3e0202
downloadaur-b8114c0f71d7ad99eeb7635fbeac282082e45705.tar.gz
pkgbuild & .srcinfo added
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e98bbe1034c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nama-gui
+ pkgdesc = This tool uses nmcli to easily set your network configuration with GUI
+ pkgver = 1.0.2.r0.g8e4c7c4
+ pkgrel = 1
+ url = https://github.com/bigrush/nama-gui
+ arch = any
+ license = GPLv3
+ depends = bash
+ depends = nama
+ depends = zenity
+ source = nama-gui::git+https://github.com/bigrush/nama-gui.git
+ md5sums = SKIP
+
+pkgname = nama-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87a7b035c0ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tom Harpaz <bigrush@protonmail.com>
+# Maintainer: Chen Tondovsko <chn566@gmail.com>
+
+pkgname=nama-gui
+pkgver=1.0.2.r0.g8e4c7c4
+pkgrel=1
+pkgdesc="This tool uses nmcli to easily set your network configuration with GUI"
+arch=('any')
+url="https://github.com/bigrush/nama-gui"
+license=('GPLv3')
+depends=('bash' 'nama' 'zenity')
+source=("$pkgname::git+https://github.com/bigrush/nama-gui.git")
+
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE.md "$pkgdir/usr/share/licenses/nama-gui/LICENSE.md"
+}
+