summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeZee2015-06-29 23:23:24 -0500
committermeZee2015-06-29 23:23:24 -0500
commitff0803d5dd6ffa3f82835322c917a7104251d56b (patch)
tree35a43208991325841f4d53b6b14cd5ce5aca74b9
downloadaur-ff0803d5dd6ffa3f82835322c917a7104251d56b.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
-rwxr-xr-xnamecoin-qt.desktop19
-rw-r--r--namecoin-qt.install11
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c4a1c43176c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = namecoin
+ pkgver = 0.3.80
+ pkgrel = 2
+ url = http://namecoin.info
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = qt5-base
+ makedepends = miniupnpc
+ makedepends = desktop-file-utils
+ makedepends = qt5-tools
+ source = https://github.com/namecoin/namecoin/archive/nc0.3.80.tar.gz
+ source = namecoin-qt.desktop
+ sha256sums = 3f5e5af95cea46111d3cf1663f0e84d5fda653917745e0607a3ca4773baea59c
+ sha256sums = d58f684fb11d8879c5f9fe7ab6c70f1a522d4f76a885e39a2e15157c1d30522e
+
+pkgname = namecoin-qt
+ pkgdesc = Namecoin is a decentralized open source information registration and transfer system based on the Bitcoin cryptocurrency.
+ install = namecoin-qt.install
+ depends = boost-libs
+ depends = qt5-base
+ depends = miniupnpc
+ depends = desktop-file-utils
+ conflicts = namecoin-qt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fd30c1c5740
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: William Grieshaber <me@zee.li>
+# Contributor: portals <portals@gmail.com>
+
+pkgbase=namecoin
+pkgname=('namecoin-qt')
+pkgver=0.3.80
+pkgrel=2
+arch=('i686' 'x86_64')
+url="http://namecoin.info"
+makedepends=('boost' 'qt5-base' 'miniupnpc' 'desktop-file-utils' 'qt5-tools')
+license=('MIT')
+source=(https://github.com/namecoin/namecoin/archive/nc$pkgver.tar.gz
+ 'namecoin-qt.desktop')
+sha256sums=('3f5e5af95cea46111d3cf1663f0e84d5fda653917745e0607a3ca4773baea59c'
+ 'd58f684fb11d8879c5f9fe7ab6c70f1a522d4f76a885e39a2e15157c1d30522e')
+
+build() {
+ cd "$srcdir/$pkgbase-nc$pkgver/"
+ qmake-qt5 "USE_UPNP=-" # I can't find a way to compile with UPNP
+ make
+
+}
+
+package_namecoin-qt() {
+ pkgdesc="Namecoin is a decentralized open source information registration and transfer system based on the Bitcoin cryptocurrency."
+ depends=(boost-libs qt5-base miniupnpc desktop-file-utils)
+ conflicts=(namecoin-qt-git)
+ install=namecoin-qt.install
+ cd "$srcdir/$pkgbase-nc$pkgver/"
+ install -Dm755 namecoin-qt "$pkgdir"/usr/bin/namecoin-qt
+ install -Dm644 "$srcdir"/namecoin-qt.desktop \
+ "$pkgdir"/usr/share/applications/namecoin-qt.desktop
+
+}
+
diff --git a/namecoin-qt.desktop b/namecoin-qt.desktop
new file mode 100755
index 000000000000..5ddbf7abb79e
--- /dev/null
+++ b/namecoin-qt.desktop
@@ -0,0 +1,19 @@
+[Desktop Entry]
+Comment[en_US]=
+Comment=
+Exec=namecoin-qt %u
+GenericName[en_US]=Namecoin is a decentralized open source information registration and transfer system based on the Bitcoin cryptocurrency.\s
+GenericName=Namecoin is a decentralized open source information registration and transfer system based on the Bitcoin cryptocurrency.\s
+Icon=exec
+MimeType=
+Name[en_US]=Namecoin
+Name=Namecoin
+Path=
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/namecoin-qt.install b/namecoin-qt.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/namecoin-qt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}