summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2018-01-21 20:42:29 -0800
committerMaximilian Weiss2018-01-21 20:42:29 -0800
commit3d92e1a7a851190b17c72e38bac0f1fff5d07e7e (patch)
tree331d4d36cf280f134895aaa2c25a8f13daf389ae
parenta1d1d787d59ef4b504fe243d8eb4113b8bd82ef1 (diff)
downloadaur-3d92e1a7a851190b17c72e38bac0f1fff5d07e7e.tar.gz
Updated to 0.15.99 release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
-rw-r--r--patch.diff99
3 files changed, 87 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58b366c839ea..73e4e0ceec2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = namecoin-core-wallet
pkgdesc = This package provides the Namecoin Core GUI client and CLI daemon. This package does not create a systemd service.
- pkgver = v0.13.99.name.tab.beta1
- pkgrel = 10
- epoch = 1511029686
+ pkgver = v0.15.99.name.tab.beta1
+ pkgrel = 1
+ epoch = 1516571444
url = https://namecoin.org/
arch = i686
arch = x86_64
@@ -36,7 +36,7 @@ pkgbase = namecoin-core-wallet
sha256sums = SKIP
sha256sums = 0226f5a570bbbde63f332d43d9d712287b316c726280f2ae9e21b1b365b3f0dc
sha256sums = f1e0593b872e18e0aebbf399bb5d77be255cb0aa160964c0528698a33f89ba04
- sha256sums = e34a576066c39b2ca4ad192683b3c75fe86c9fedc30176dc60306d539863a139
+ sha256sums = 52ac2022fabd9b1428956b8202788f564d00c1778f5c7e78dd960c6ad6c70db0
pkgname = namecoin-core-wallet
diff --git a/PKGBUILD b/PKGBUILD
index b3ca71ca7d54..eab14631fe57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Maximilian Weiss <$(echo "bWF4QG1heHdlaXNzLmlv" | base64 -d)>
-# Contributor: Daniel Kraft <$(echo "ZEBkb21vYi5ldQo=" | base64 -d)>
# Contributor: Jeremy Rand <$(echo "YmlvbGl6YXJkODlAZ21haWwuY29tCg==" | base64 -d)>
+# Contributor: Daniel Kraft <$(echo "ZEBkb21vYi5ldQo=" | base64 -d)>
# Contributor: The Namecoin Core Developers
# Contributor: The Bitcoin Core Developers
pkgname=namecoin-core-wallet
-pkgver=v0.13.99.name.tab.beta1
-pkgrel=10
+pkgver=v0.15.99.name.tab.beta1
+pkgrel=1
# Epoch is always set to the most recent PKGBUILD update time.
# This allows for a forced downgrade without messing up versioning.
-epoch=1511029686
+epoch=1516571444
-# Release commit for nc0.13.99-name-tab-beta1
-_commit=a11e75411af3b612a36e3516e461934838c0c53b
+# Release commit for nc0.15.99-name-tab-beta1
+_commit=fab005af18da02cad6b48b9d218e73d2c3eecd4d
pkgdesc='This package provides the Namecoin Core GUI client and CLI daemon.'
@@ -38,15 +38,19 @@ source=('git://github.com/namecoin/namecoin-core'
sha256sums=('SKIP'
'0226f5a570bbbde63f332d43d9d712287b316c726280f2ae9e21b1b365b3f0dc'
'f1e0593b872e18e0aebbf399bb5d77be255cb0aa160964c0528698a33f89ba04'
- 'e34a576066c39b2ca4ad192683b3c75fe86c9fedc30176dc60306d539863a139')
-
+ '52ac2022fabd9b1428956b8202788f564d00c1778f5c7e78dd960c6ad6c70db0')
-build() {
+prepare() {
mkdir -p "$srcdir/tmp"
cd "$srcdir/namecoin-core/"
git checkout "$_commit"
cd "$srcdir/"
patch -p0 -i patch.diff
+}
+
+
+build() {
+
cd "$srcdir/namecoin-core/"
./autogen.sh
@@ -91,3 +95,5 @@ package() {
ln -s "libnamecoinconsensus.so.0.0.0" "libnamecoinconsensus.so.0"
ln -s "libnamecoinconsensus.so.0.0.0" "libnamecoinconsensus.so"
}
+
+
diff --git a/patch.diff b/patch.diff
index 88e7a2122799..6a86220e5556 100644
--- a/patch.diff
+++ b/patch.diff
@@ -1,32 +1,69 @@
---- ./namecoin-core/src/qt/paymentrequestplus.cpp 2017-09-07 13:25:08.110842918 -0700
-+++ ./namecoin-core/src/qt/paymentrequestplus.cpp 2017-09-07 13:36:34.394547631 -0700
-@@ -159,14 +159,24 @@
- std::string data_to_verify; // Everything but the signature
- rcopy.SerializeToString(&data_to_verify);
+--- ./namecoin-core/src/miner.h
++++ ./namecoin-core/src/miner.h
+@@ -71,7 +71,7 @@
+ // except operating on CTxMemPoolModifiedEntry.
+ // TODO: refactor to avoid duplication of this logic.
+ struct CompareModifiedEntry {
+- bool operator()(const CTxMemPoolModifiedEntry &a, const CTxMemPoolModifiedEntry &b)
++ bool operator()(const CTxMemPoolModifiedEntry &a, const CTxMemPoolModifiedEntry &b) const
+ {
+ double f1 = (double)a.nModFeesWithAncestors * b.nSizeWithAncestors;
+ double f2 = (double)b.nModFeesWithAncestors * a.nSizeWithAncestors;
+@@ -86,7 +86,7 @@
+ // This is sufficient to sort an ancestor package in an order that is valid
+ // to appear in a block.
+ struct CompareTxIterByAncestorCount {
+- bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b)
++ bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b) const
+ {
+ if (a->GetCountWithAncestors() != b->GetCountWithAncestors())
+ return a->GetCountWithAncestors() < b->GetCountWithAncestors();
+---
+--- ./namecoin-core/src/txmempool.h
++++ ./namecoin-core/src/txmempool.h
+@@ -235,7 +235,7 @@
+ class CompareTxMemPoolEntryByDescendantScore
+ {
+ public:
+- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+ {
+ bool fUseADescendants = UseDescendantScore(a);
+ bool fUseBDescendants = UseDescendantScore(b);
+@@ -257,7 +257,7 @@
+ }
-- EVP_MD_CTX ctx;
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+ EVP_MD_CTX *ctx = EVP_MD_CTX_new();
-+ if (!ctx) throw SSLVerifyError("Error allocating OpenSSL context.");
-+#else
-+ EVP_MD_CTX _ctx;
-+ EVP_MD_CTX *ctx;
-+ ctx = &_ctx;
-+#endif
- EVP_PKEY *pubkey = X509_get_pubkey(signing_cert);
-- EVP_MD_CTX_init(&ctx);
-- if (!EVP_VerifyInit_ex(&ctx, digestAlgorithm, NULL) ||
-- !EVP_VerifyUpdate(&ctx, data_to_verify.data(), data_to_verify.size()) ||
-- !EVP_VerifyFinal(&ctx, (const unsigned char*)paymentRequest.signature().data(), (unsigned int)paymentRequest.signature().size(), pubkey)) {
-+ EVP_MD_CTX_init(ctx);
-+ if (!EVP_VerifyInit_ex(ctx, digestAlgorithm, NULL) ||
-+ !EVP_VerifyUpdate(ctx, data_to_verify.data(), data_to_verify.size()) ||
-+ !EVP_VerifyFinal(ctx, (const unsigned char*)paymentRequest.signature().data(), (unsigned int)paymentRequest.signature().size(), pubkey)) {
- throw SSLVerifyError("Bad signature, invalid payment request.");
- }
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+ EVP_MD_CTX_free(ctx);
-+#endif
-
- // OpenSSL API for getting human printable strings from certs is baroque.
- int textlen = X509_NAME_get_text_by_NID(certname, NID_commonName, NULL, 0);
+ // Calculate which score to use for an entry (avoiding division).
+- bool UseDescendantScore(const CTxMemPoolEntry &a)
++ bool UseDescendantScore(const CTxMemPoolEntry &a) const
+ {
+ double f1 = (double)a.GetModifiedFee() * a.GetSizeWithDescendants();
+ double f2 = (double)a.GetModFeesWithDescendants() * a.GetTxSize();
+@@ -272,7 +272,7 @@
+ class CompareTxMemPoolEntryByScore
+ {
+ public:
+- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+ {
+ double f1 = (double)a.GetModifiedFee() * b.GetTxSize();
+ double f2 = (double)b.GetModifiedFee() * a.GetTxSize();
+@@ -286,7 +286,7 @@
+ class CompareTxMemPoolEntryByEntryTime
+ {
+ public:
+- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+ {
+ return a.GetTime() < b.GetTime();
+ }
+@@ -295,7 +295,7 @@
+ class CompareTxMemPoolEntryByAncestorFee
+ {
+ public:
+- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
++ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
+ {
+ double aFees = a.GetModFeesWithAncestors();
+ double aSize = a.GetSizeWithAncestors();
+