summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2018-11-14 15:40:01 -0800
committerMaximilian Weiss2018-11-14 15:40:01 -0800
commit4fcd6c077d73aab090ce0a87a06083ee22b71d7d (patch)
tree42efd6c9cdd0f41931c67f5f079de32928cc9568
parent70cfb0f13db92ca284de91f74df8c8bb799050cd (diff)
downloadaur-4fcd6c077d73aab090ce0a87a06083ee22b71d7d.tar.gz
Updated to v0.17, added systemd user service for namecoind
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--namecoind.service13
-rw-r--r--namecoind@.service14
-rw-r--r--patch.diff6
5 files changed, 54 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 804375b63461..a0db8231d979 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = namecoin-core-wallet
- pkgdesc = This package provides the Namecoin Core GUI client and CLI daemon. This package does not create a systemd service.
- pkgver = v0.16.3
- pkgrel = 2
- epoch = 1538009445
+ pkgdesc = This package provides the Namecoin Core GUI client, CLI daemon, and daemon user service.
+ pkgver = v0.17.0
+ pkgrel = 1
+ epoch = 1542235176
url = https://namecoin.org/
arch = i686
arch = x86_64
@@ -32,11 +32,15 @@ pkgbase = namecoin-core-wallet
source = git://github.com/namecoin/namecoin-core
source = namecoin.desktop
source = namecoin1500x1500.png
+ source = namecoind.service
+ source = namecoind@.service
source = patch.diff
sha256sums = SKIP
sha256sums = 0226f5a570bbbde63f332d43d9d712287b316c726280f2ae9e21b1b365b3f0dc
sha256sums = f1e0593b872e18e0aebbf399bb5d77be255cb0aa160964c0528698a33f89ba04
- sha256sums = 59367280936748c3f10fdea0eb7c21e2407b522617a9856dcd43ce7417e8d6a8
+ sha256sums = 0a8cb03f33a895ccaed63fb9d946db69bee7188b7a9f41bc92879167c2718dcf
+ sha256sums = 216bf1642feb5c37cc82a0801faf0717308f98e5aed86d75dac8fafd150a4b68
+ sha256sums = c1918615ac36cd265210fe3d6d1c76591aa740fbb8e359b47f5d73d7979896e1
pkgname = namecoin-core-wallet
diff --git a/PKGBUILD b/PKGBUILD
index 3b3529cb19f1..3ad18ea21556 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,20 @@
pkgname=namecoin-core-wallet
-pkgver=v0.16.3
-pkgrel=2
+pkgver=v0.17.0
+pkgrel=1
# Epoch is always set to the most recent PKGBUILD update time.
# This allows for a forced downgrade without messing up versioning.
-epoch=1538009445
+epoch=1542235176
-# Release commit for 0.16.3
-_commit=6fdea2aedfbcf0e8c24ce1552f7f58950e5efb55
+# Release commit for 0.17.0
+_commit=00a5f525720a408fac2467a251ce11691d2699b4
-pkgdesc='This package provides the Namecoin Core GUI client and CLI daemon.'
-pkgdesc="$pkgdesc This package does not create a systemd service."
+pkgdesc='This package provides the Namecoin Core GUI client, CLI daemon, and daemon user service.'
arch=('i686' 'x86_64')
url='https://namecoin.org/'
@@ -34,11 +33,15 @@ conflicts=('namecoin-core-wallet' 'namecoin-cli' 'namecoin-daemon'
source=('git://github.com/namecoin/namecoin-core'
'namecoin.desktop'
'namecoin1500x1500.png'
+ 'namecoind.service'
+ 'namecoind@.service'
'patch.diff')
sha256sums=('SKIP'
'0226f5a570bbbde63f332d43d9d712287b316c726280f2ae9e21b1b365b3f0dc'
'f1e0593b872e18e0aebbf399bb5d77be255cb0aa160964c0528698a33f89ba04'
- '59367280936748c3f10fdea0eb7c21e2407b522617a9856dcd43ce7417e8d6a8')
+ '0a8cb03f33a895ccaed63fb9d946db69bee7188b7a9f41bc92879167c2718dcf'
+ '216bf1642feb5c37cc82a0801faf0717308f98e5aed86d75dac8fafd150a4b68'
+ 'c1918615ac36cd265210fe3d6d1c76591aa740fbb8e359b47f5d73d7979896e1')
prepare() {
@@ -95,7 +98,10 @@ package() {
install -Dm644 "$srcdir/namecoin-core/COPYING" "$pkgdir/usr/share/licenses/namecoin/COPYING"
install -Dm644 "$srcdir/tmp/usr/include/namecoinconsensus.h" "$pkgdir/usr/include/namecoinconsensus.h"
install -Dm644 "$srcdir/tmp/usr/lib/libnamecoinconsensus.so.0.0.0" "$pkgdir/usr/lib/libnamecoinconsensus.so.0.0.0"
+ install -Dm644 "$srcdir/namecoind@.service" "$pkgdir/usr/lib/systemd/system/namecoind@.service"
+ install -Dm644 "$srcdir/namecoind.service" "$pkgdir/usr/lib/systemd/user/namecoind.service"
cd "$pkgdir/usr/lib/"
ln -s "libnamecoinconsensus.so.0.0.0" "libnamecoinconsensus.so.0"
ln -s "libnamecoinconsensus.so.0.0.0" "libnamecoinconsensus.so"
}
+
diff --git a/namecoind.service b/namecoind.service
new file mode 100644
index 000000000000..ba9154b4b49c
--- /dev/null
+++ b/namecoind.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Namecoin Core Daemon
+After=local-fs.target network.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/usr/bin/namecoind
+ExecStop=/usr/bin/namecoin-cli stop
+
+[Install]
+WantedBy=default.target
+
diff --git a/namecoind@.service b/namecoind@.service
new file mode 100644
index 000000000000..8c566c63f053
--- /dev/null
+++ b/namecoind@.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Namecoin Core Daemon
+After=local-fs.target network.target
+
+[Service]
+Type=oneshot
+RemainAfterExit=yes
+ExecStart=/usr/bin/namecoind
+ExecStop=/usr/bin/namecoin-cli stop
+User=%I
+
+[Install]
+WantedBy=default.target
+
diff --git a/patch.diff b/patch.diff
index 5a41a728e296..23ffce43a635 100644
--- a/patch.diff
+++ b/patch.diff
@@ -1,11 +1,13 @@
--- ./namecoin-core/src/qt/bitcoin.cpp
+++ ./namecoin-core/src/qt/bitcoin.cpp
-@@ -573,14 +573,22 @@
+@@ -576,14 +576,24 @@
#ifdef Q_OS_MAC
QApplication::setAttribute(Qt::AA_DontShowIconsInMenus);
#endif
+
-+// Includes fixes proposed by eserlxl in post #7 on https://bbs.archlinux.org/viewtopic.php?id=240553
++
++// Includes fixes proposed by eserlxl in post #7 of https://bbs.archlinux.org/viewtopic.php?id=240553
++// See patch file in package details of AUR package
#if QT_VERSION >= 0x050500
+ QSslSocket::sslLibraryVersionString();
+ Q_ASSERT( QSslSocket::supportsSsl() );