summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2017-11-18 13:41:53 -0800
committerMaximilian Weiss2017-11-18 13:41:53 -0800
commita1d1d787d59ef4b504fe243d8eb4113b8bd82ef1 (patch)
tree0c67a67b54929c103217c346c47a5b2770c1fdd6
parentfe1b747fc43694694e838fc1afff68807c8f173f (diff)
downloadaur-a1d1d787d59ef4b504fe243d8eb4113b8bd82ef1.tar.gz
Made static build for x64
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD43
2 files changed, 38 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82e5dd4fa6ed..58b366c839ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = namecoin-core-wallet
pkgdesc = This package provides the Namecoin Core GUI client and CLI daemon. This package does not create a systemd service.
pkgver = v0.13.99.name.tab.beta1
- pkgrel = 9
- epoch = 1506676810
+ pkgrel = 10
+ epoch = 1511029686
url = https://namecoin.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7edc3f802d51..b3ca71ca7d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,22 +7,30 @@
pkgname=namecoin-core-wallet
pkgver=v0.13.99.name.tab.beta1
-pkgrel=9
+pkgrel=10
+
# Epoch is always set to the most recent PKGBUILD update time.
# This allows for a forced downgrade without messing up versioning.
-epoch=1506676810
+epoch=1511029686
+
# Release commit for nc0.13.99-name-tab-beta1
_commit=a11e75411af3b612a36e3516e461934838c0c53b
-pkgdesc='This package provides the Namecoin Core GUI client and CLI daemon. This package does not create a systemd service.'
+
+pkgdesc='This package provides the Namecoin Core GUI client and CLI daemon.'
+pkgdesc="$pkgdesc This package does not create a systemd service."
+
arch=('i686' 'x86_64')
url='https://namecoin.org/'
license=('MIT')
-depends=('desktop-file-utils' 'openssl' 'db4.8' 'boost' 'boost-libs' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq')
-provides=('namecoin-core-wallet' 'namecoin-cli' 'namecoin-daemon' 'namecoin-qt' 'namecoin-tx')
-conflicts=('namecoin-core-wallet' 'namecoin-cli' 'namecoin-daemon' 'namecoin-qt' 'namecoin-tx')
+depends=('desktop-file-utils' 'openssl' 'db4.8' 'boost' 'boost-libs' 'libevent'
+ 'qt5-base' 'qt5-tools' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq')
+provides=('namecoin-core-wallet' 'namecoin-cli' 'namecoin-daemon'
+ 'namecoin-qt' 'namecoin-tx')
+conflicts=('namecoin-core-wallet' 'namecoin-cli' 'namecoin-daemon'
+ 'namecoin-qt' 'namecoin-tx')
source=('git://github.com/namecoin/namecoin-core'
'namecoin.desktop'
'namecoin1500x1500.png'
@@ -32,6 +40,7 @@ sha256sums=('SKIP'
'f1e0593b872e18e0aebbf399bb5d77be255cb0aa160964c0528698a33f89ba04'
'e34a576066c39b2ca4ad192683b3c75fe86c9fedc30176dc60306d539863a139')
+
build() {
mkdir -p "$srcdir/tmp"
cd "$srcdir/namecoin-core/"
@@ -40,11 +49,31 @@ build() {
patch -p0 -i patch.diff
cd "$srcdir/namecoin-core/"
./autogen.sh
- ./configure --prefix=/usr --enable-upnp-default --enable-hardening --with-gui=qt5 --disable-tests
+
+ # I have not tested the static build process on 32 bit machines yet,
+ # so I'm leaving i686 with the normal dynamic build.
+ if [ "$CARCH" == i686 ]; then
+ ./configure --prefix=/usr --enable-upnp-default --enable-hardening \
+ --with-gui=qt5 --disable-tests
+
+ # This should produce a static build that doesn't brick every time Arch
+ # rolls out updates to the system libraries.
+ elif [ "$CARCH" == x86_64 ]; then
+ ./configure LDFLAGS="-static-libstdc++" \
+ --prefix=/usr \
+ --enable-glibc-back-compat \
+ --enable-reduce-exports \
+ --enable-upnp-default \
+ --enable-hardening \
+ --with-gui=qt5 \
+ --disable-tests
+ fi
+
make DESTDIR="$srcdir/tmp"
make DESTDIR="$srcdir/tmp" install
}
+
# Namecoin does not include any man pages.
# Or rather, it has Bitcoin's man pages completely unchanged.
# Therefore, I have not included them in the package.