summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2018-02-19 06:42:56 -0800
committerMaximilian Weiss2018-02-19 06:42:56 -0800
commitee953addcc41430643202601eb63e2bf3a3b060c (patch)
tree25664b767cdab29ad7b1aa044cd016d9093da7ac
parent3d92e1a7a851190b17c72e38bac0f1fff5d07e7e (diff)
downloadaur-ee953addcc41430643202601eb63e2bf3a3b060c.tar.gz
Upgraded to 0.15.99 beta2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--patch.diff69
3 files changed, 7 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73e4e0ceec2f..6f04e600b3ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = namecoin-core-wallet
pkgdesc = This package provides the Namecoin Core GUI client and CLI daemon. This package does not create a systemd service.
- pkgver = v0.15.99.name.tab.beta1
+ pkgver = v0.15.99.name.tab.beta2
pkgrel = 1
- epoch = 1516571444
+ epoch = 1519047664
url = https://namecoin.org/
arch = i686
arch = x86_64
@@ -32,11 +32,9 @@ pkgbase = namecoin-core-wallet
source = git://github.com/namecoin/namecoin-core
source = namecoin.desktop
source = namecoin1500x1500.png
- source = patch.diff
sha256sums = SKIP
sha256sums = 0226f5a570bbbde63f332d43d9d712287b316c726280f2ae9e21b1b365b3f0dc
sha256sums = f1e0593b872e18e0aebbf399bb5d77be255cb0aa160964c0528698a33f89ba04
- sha256sums = 52ac2022fabd9b1428956b8202788f564d00c1778f5c7e78dd960c6ad6c70db0
pkgname = namecoin-core-wallet
diff --git a/PKGBUILD b/PKGBUILD
index eab14631fe57..63811816d47c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,17 @@
pkgname=namecoin-core-wallet
-pkgver=v0.15.99.name.tab.beta1
+pkgver=v0.15.99.name.tab.beta2
pkgrel=1
# Epoch is always set to the most recent PKGBUILD update time.
# This allows for a forced downgrade without messing up versioning.
-epoch=1516571444
+epoch=1519047664
# Release commit for nc0.15.99-name-tab-beta1
-_commit=fab005af18da02cad6b48b9d218e73d2c3eecd4d
+_commit=570a54769056680b1204194fd9a4de94852c8fe7
pkgdesc='This package provides the Namecoin Core GUI client and CLI daemon.'
@@ -33,19 +33,14 @@ conflicts=('namecoin-core-wallet' 'namecoin-cli' 'namecoin-daemon'
'namecoin-qt' 'namecoin-tx')
source=('git://github.com/namecoin/namecoin-core'
'namecoin.desktop'
- 'namecoin1500x1500.png'
- 'patch.diff')
+ 'namecoin1500x1500.png')
sha256sums=('SKIP'
'0226f5a570bbbde63f332d43d9d712287b316c726280f2ae9e21b1b365b3f0dc'
- 'f1e0593b872e18e0aebbf399bb5d77be255cb0aa160964c0528698a33f89ba04'
- '52ac2022fabd9b1428956b8202788f564d00c1778f5c7e78dd960c6ad6c70db0')
-
+ 'f1e0593b872e18e0aebbf399bb5d77be255cb0aa160964c0528698a33f89ba04')
prepare() {
mkdir -p "$srcdir/tmp"
cd "$srcdir/namecoin-core/"
git checkout "$_commit"
- cd "$srcdir/"
- patch -p0 -i patch.diff
}
diff --git a/patch.diff b/patch.diff
deleted file mode 100644
index 6a86220e5556..000000000000
--- a/patch.diff
+++ /dev/null
@@ -1,69 +0,0 @@
---- ./namecoin-core/src/miner.h
-+++ ./namecoin-core/src/miner.h
-@@ -71,7 +71,7 @@
- // except operating on CTxMemPoolModifiedEntry.
- // TODO: refactor to avoid duplication of this logic.
- struct CompareModifiedEntry {
-- bool operator()(const CTxMemPoolModifiedEntry &a, const CTxMemPoolModifiedEntry &b)
-+ bool operator()(const CTxMemPoolModifiedEntry &a, const CTxMemPoolModifiedEntry &b) const
- {
- double f1 = (double)a.nModFeesWithAncestors * b.nSizeWithAncestors;
- double f2 = (double)b.nModFeesWithAncestors * a.nSizeWithAncestors;
-@@ -86,7 +86,7 @@
- // This is sufficient to sort an ancestor package in an order that is valid
- // to appear in a block.
- struct CompareTxIterByAncestorCount {
-- bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b)
-+ bool operator()(const CTxMemPool::txiter &a, const CTxMemPool::txiter &b) const
- {
- if (a->GetCountWithAncestors() != b->GetCountWithAncestors())
- return a->GetCountWithAncestors() < b->GetCountWithAncestors();
----
---- ./namecoin-core/src/txmempool.h
-+++ ./namecoin-core/src/txmempool.h
-@@ -235,7 +235,7 @@
- class CompareTxMemPoolEntryByDescendantScore
- {
- public:
-- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
-+ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
- {
- bool fUseADescendants = UseDescendantScore(a);
- bool fUseBDescendants = UseDescendantScore(b);
-@@ -257,7 +257,7 @@
- }
-
- // Calculate which score to use for an entry (avoiding division).
-- bool UseDescendantScore(const CTxMemPoolEntry &a)
-+ bool UseDescendantScore(const CTxMemPoolEntry &a) const
- {
- double f1 = (double)a.GetModifiedFee() * a.GetSizeWithDescendants();
- double f2 = (double)a.GetModFeesWithDescendants() * a.GetTxSize();
-@@ -272,7 +272,7 @@
- class CompareTxMemPoolEntryByScore
- {
- public:
-- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
-+ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
- {
- double f1 = (double)a.GetModifiedFee() * b.GetTxSize();
- double f2 = (double)b.GetModifiedFee() * a.GetTxSize();
-@@ -286,7 +286,7 @@
- class CompareTxMemPoolEntryByEntryTime
- {
- public:
-- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
-+ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
- {
- return a.GetTime() < b.GetTime();
- }
-@@ -295,7 +295,7 @@
- class CompareTxMemPoolEntryByAncestorFee
- {
- public:
-- bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b)
-+ bool operator()(const CTxMemPoolEntry& a, const CTxMemPoolEntry& b) const
- {
- double aFees = a.GetModFeesWithAncestors();
- double aSize = a.GetSizeWithAncestors();
-