summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2019-04-10 16:27:17 +0200
committerWilken 'Akiko' Gottwalt2019-04-10 16:27:17 +0200
commit12b41c4b771d00eb52f2404c5255cba312323d66 (patch)
tree60860f2affe8d446f37a6ca87f90c17a1b0dcc4a
parentbba1d0bd1c2673eb39eb12618fa6e40dc39f5c07 (diff)
downloadaur-12b41c4b771d00eb52f2404c5255cba312323d66.tar.gz
updated nana to version 1.7.0
- fixed some source code issues - fixed some buildsystem issues - changed build process to include shared and static libs
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
-rw-r--r--fix_all_the_little_issues.patch83
3 files changed, 114 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fb4fdf98b49..584722bb3ad8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nana
pkgdesc = An opensource cross-platform GUI library written in modern C++11 for static linking
- pkgver = 1.6.2
+ pkgver = 1.7.0
pkgrel = 1
url = http://nanapro.org/en-us/
arch = i686
@@ -18,8 +18,10 @@ pkgbase = nana
depends = libpng
depends = libx11
depends = libxft
- source = http://downloads.sourceforge.net/project/nanapro/Nana/Nana 1.x/nana 1.6.2.zip
- sha256sums = 02161819c86ee95a78bc7618bacb7b116d2d89dfe91c0d2c69eaea8f164795a8
+ source = https://sourceforge.net/projects/nanapro/files/Nana/Nana 1.x/nana 1.7.0.zip
+ source = fix_all_the_little_issues.patch
+ sha256sums = b54b7754d702d5a3e27191645c5305a3769d14e830b9e96ecacf2d3c4801d2a1
+ sha256sums = eb11ea2cd35c59522f54730513dae4089414fbf87bfc903408de6cf6fdf3942b
pkgname = nana
diff --git a/PKGBUILD b/PKGBUILD
index 44f21e527e31..cabde648c2a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
pkgname=nana
-pkgver=1.6.2
+pkgver=1.7.0
pkgrel=1
pkgdesc="An opensource cross-platform GUI library written in modern C++11 for static linking"
arch=("i686" "x86_64")
@@ -9,11 +9,15 @@ url="http://nanapro.org/en-us/"
license=("custom:Boost Software License")
depends=("alsa-lib" "libjpeg-turbo" "libpng" "libx11" "libxft")
makedepends=("alsa-lib" "cmake" "libjpeg-turbo" "libpng" "libx11" "libxft" "xorgproto")
-source=("http://downloads.sourceforge.net/project/nanapro/Nana/Nana 1.x/${pkgname} ${pkgver}.zip")
-sha256sums=('02161819c86ee95a78bc7618bacb7b116d2d89dfe91c0d2c69eaea8f164795a8')
+source=("https://sourceforge.net/projects/nanapro/files/Nana/Nana 1.x/nana 1.7.0.zip"
+ "fix_all_the_little_issues.patch")
+sha256sums=('b54b7754d702d5a3e27191645c5305a3769d14e830b9e96ecacf2d3c4801d2a1'
+ 'eb11ea2cd35c59522f54730513dae4089414fbf87bfc903408de6cf6fdf3942b')
prepare() {
cd ${srcdir}/${pkgname}
+
+ patch -Np1 -i ../fix_all_the_little_issues.patch
}
build() {
@@ -22,13 +26,31 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DNANA_CMAKE_ENABLE_AUDIO=YES \
+ -DNANA_CMAKE_ENABLE_JPEG=YES \
+ -DNANA_CMAKE_ENABLE_PNG=YES \
+ -DNANA_CMAKE_INSTALL=YES \
-DNANA_CMAKE_NANA_FILESYSTEM_FORCE=YES
+ make
+ cmake \
+ -DBUILD_SHARED_LIBS=YES \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DNANA_CMAKE_ENABLE_AUDIO=YES \
+ -DNANA_CMAKE_ENABLE_JPEG=YES \
+ -DNANA_CMAKE_ENABLE_PNG=YES \
+ -DNANA_CMAKE_INSTALL=YES \
+ -DNANA_CMAKE_NANA_FILESYSTEM_FORCE=YES
make
}
package() {
cd ${srcdir}/${pkgname}
- make DESTDIR="${pkgdir}" install
+ cp libnana.a "${pkgdir}"/
+ cp libnana.so "${pkgdir}"/libnana.so.${pkgver}
+ cd "${pkgdir}"
+ ln -s libnana.so.${pkgver} libnana.so.1.7
+ ln -s libnana.so.${pkgver} libnana.so.1
}
diff --git a/fix_all_the_little_issues.patch b/fix_all_the_little_issues.patch
new file mode 100644
index 000000000000..ec02eafd1a56
--- /dev/null
+++ b/fix_all_the_little_issues.patch
@@ -0,0 +1,83 @@
+Fixes all the little issues with that new version. This is some kind of
+joke, isn't it? Did they even test the stuff? Ah well...
+---
+diff -urpN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2019-04-10 14:56:59.945587369 +0200
++++ b/CMakeLists.txt 2019-04-10 16:03:20.072383378 +0200
+@@ -22,10 +22,10 @@
+ # cmake 3.12 have more better modern c++ support
+
+ cmake_minimum_required(VERSION 3.12 FATAL_ERROR)
+-project(nana VERSION 1.6.2
++project(nana VERSION 1.7.0
+ DESCRIPTION "C++ GUI library"
+ HOMEPAGE_URL http://nanapro.org
+- LANGUAGES CXX )
++ LANGUAGES CXX)
+
+ ####################### Main setting of Nana targets, sources and installs #####################
+
+diff -urpN a/build/cmake/compilers.cmake b/build/cmake/compilers.cmake
+--- a/build/cmake/compilers.cmake 2019-04-10 14:56:59.945587369 +0200
++++ b/build/cmake/compilers.cmake 2019-04-10 15:53:36.754700500 +0200
+@@ -15,7 +15,7 @@
+ if(CMAKE_COMPILER_IS_GNUCXX OR "${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang") # AND NOT MINGW??
+
+ target_compile_options(nana PRIVATE -Wall
+- PUBLIC -g )
++ PUBLIC -Os -s)
+
+ set(THREADS_PREFER_PTHREAD_FLAG ON) # todo - test this
+ find_package(Threads REQUIRED)
+diff -urpN a/build/cmake/enable_audio.cmake b/build/cmake/enable_audio.cmake
+--- a/build/cmake/enable_audio.cmake 2019-04-10 14:56:59.945587369 +0200
++++ b/build/cmake/enable_audio.cmake 2019-04-10 16:06:33.163862315 +0200
+@@ -4,12 +4,12 @@ option(NANA_CMAKE_ENABLE_AUDIO "Enable c
+ if(NANA_CMAKE_ENABLE_AUDIO)
+ target_compile_definitions(nana PUBLIC NANA_ENABLE_AUDIO)
+ if(UNIX)
+- find_package(ASOUND) # ? https://github.com/hintjens/demidi/blob/master/Findasound.cmake
+- if(ASOUND_FOUND)
+- target_include_directories(nana PUBLIC ${ASOUND_INCLUDE_DIRS})
+- target_link_libraries(nana PUBLIC ${ASOUND_LIBRARIES})
++ find_package(ALSA) # ? https://github.com/hintjens/demidi/blob/master/Findasound.cmake
++ if(ALSA_FOUND)
++ target_include_directories(nana PUBLIC ${ALSA_INCLUDE_DIRS})
++ target_link_libraries(nana PUBLIC ${ALSA_LIBRARIES})
+ else()
+ message(FATAL_ERROR "libasound is not found")
+ endif()
+ endif()
+-endif()
+\ No newline at end of file
++endif()
+diff -urpN a/source/filesystem/filesystem.cpp b/source/filesystem/filesystem.cpp
+--- a/source/filesystem/filesystem.cpp 2019-04-10 14:56:59.948920713 +0200
++++ b/source/filesystem/filesystem.cpp 2019-04-10 15:01:55.913333313 +0200
+@@ -40,7 +40,7 @@
+ #include <dirent.h>
+ #include <cstdio>
+ #include <cstring>
+- #include <errno.h>
++ #include <cerrno>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #endif
+@@ -1045,7 +1045,7 @@ namespace nana { namespace experimental
+ ::fclose(stream);
+ return bytes;
+ }
+- ec.assign(static_cast<int>(::errno), std::generic_category());
++ ec.assign(static_cast<int>(errno), std::generic_category());
+ #endif
+ return static_cast<std::uintmax_t>(-1);
+ }
+@@ -1056,7 +1056,7 @@ namespace nana { namespace experimental
+ struct tm t;
+ nana::filesystem_ext::modified_file_time(p, t);
+ std::chrono::system_clock::time_point dateTime =std::chrono::system_clock::from_time_t( mktime(&t) );
+- return dateTime;
++ return dateTime;
+ }
+
+ bool create_directory(const path& p)