summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2019-10-05 08:21:52 +0200
committerWilken 'Akiko' Gottwalt2019-10-05 08:21:52 +0200
commitf9b5da8b45f757942cf43f7b3d4c588087e7426a (patch)
treed484019ccbd699424007d3d9a6d78ac1a189e6ce
parentb98deff03f11c13e1fca0bbfcbfca09f7eecbeb7 (diff)
downloadaur-f9b5da8b45f757942cf43f7b3d4c588087e7426a.tar.gz
Bumped the version to 1.7.2. Also fixed all the little buildsystem issues
which are still in there.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--fix_all_the_little_issues.patch63
3 files changed, 21 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8be0d9d38de..8dfc91a09bad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nana
pkgdesc = An opensource cross-platform GUI library written in modern C++11 for static linking
- pkgver = 1.7.1
+ pkgver = 1.7.2
pkgrel = 1
url = http://nanapro.org/en-us/
arch = i686
@@ -18,10 +18,10 @@ pkgbase = nana
depends = libpng
depends = libx11
depends = libxft
- source = https://sourceforge.net/projects/nanapro/files/Nana/Nana 1.x/nana 1.7.1.zip
+ source = https://sourceforge.net/projects/nanapro/files/Nana/Nana 1.x/nana_1.7.2.zip
source = fix_all_the_little_issues.patch
- sha256sums = b84131a7500c70a8cabbc46a9809ee0e3b9ec0d6bc47c33cbcbc7560609cc1ea
- sha256sums = 14394fed8c1d04d9c0183ba5dbb91c54025ac27575145b4bae2a6d1fa3986ed9
+ sha256sums = 442b0e0ad899792bb97dd5b3aed0cb3d36b62fb2e0564b28604b5bcb228960c3
+ sha256sums = 0033bdd672a2acfb8fe785b15de27e8e89fc843f94340bcde814e631477e3239
pkgname = nana
diff --git a/PKGBUILD b/PKGBUILD
index 5cac7c151822..e349239ccb4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
pkgname=nana
-pkgver=1.7.1
+pkgver=1.7.2
pkgrel=1
pkgdesc="An opensource cross-platform GUI library written in modern C++11 for static linking"
arch=("i686" "x86_64")
@@ -9,10 +9,10 @@ url="http://nanapro.org/en-us/"
license=("custom:Boost Software License")
depends=("alsa-lib" "libjpeg-turbo" "libpng" "libx11" "libxft")
makedepends=("alsa-lib" "cmake" "libjpeg-turbo" "libpng" "libx11" "libxft" "xorgproto")
-source=("https://sourceforge.net/projects/nanapro/files/Nana/Nana 1.x/nana 1.7.1.zip"
+source=("https://sourceforge.net/projects/nanapro/files/Nana/Nana 1.x/nana_${pkgver}.zip"
"fix_all_the_little_issues.patch")
-sha256sums=('b84131a7500c70a8cabbc46a9809ee0e3b9ec0d6bc47c33cbcbc7560609cc1ea'
- '14394fed8c1d04d9c0183ba5dbb91c54025ac27575145b4bae2a6d1fa3986ed9')
+sha256sums=('442b0e0ad899792bb97dd5b3aed0cb3d36b62fb2e0564b28604b5bcb228960c3'
+ '0033bdd672a2acfb8fe785b15de27e8e89fc843f94340bcde814e631477e3239')
prepare() {
cd ${srcdir}/${pkgname}
diff --git a/fix_all_the_little_issues.patch b/fix_all_the_little_issues.patch
index 5a757fd34093..976c00cc303b 100644
--- a/fix_all_the_little_issues.patch
+++ b/fix_all_the_little_issues.patch
@@ -1,17 +1,18 @@
-Fixes all the little issues with that new version. This is some kind of
-joke, isn't it? Did they even test the stuff? Ah well...
+Fixed some of the cmake buildsystem issues. They still forget to set the
+proper version and still seam to not check the Linux builds. CMake
+provides an ALSA module for a long time now ...
---
-diff -urpN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2019-03-11 22:52:18.000000000 +0100
-+++ b/CMakeLists.txt 2019-05-12 18:03:25.279901510 +0200
+diff -urpN nana.orig/CMakeLists.txt nana/CMakeLists.txt
+--- nana.orig/CMakeLists.txt 2019-10-05 08:13:02.018317259 +0200
++++ nana/CMakeLists.txt 2019-10-05 08:13:38.796748368 +0200
@@ -21,11 +21,11 @@
# https://cmake.org/cmake/help/v3.12/module/CMakeDependentOption.html?highlight=cmakedependentoption
# cmake 3.12 have more better modern c++ support
-cmake_minimum_required(VERSION 3.12 FATAL_ERROR)
--project(nana VERSION 1.6.2
+-project(nana VERSION 1.7.1
+cmake_minimum_required(VERSION 3.12 FATAL_ERROR)
-+project(nana VERSION 1.7.1
++project(nana VERSION 1.7.2
DESCRIPTION "C++ GUI library"
HOMEPAGE_URL http://nanapro.org
- LANGUAGES CXX )
@@ -19,23 +20,9 @@ diff -urpN a/CMakeLists.txt b/CMakeLists.txt
####################### Main setting of Nana targets, sources and installs #####################
-diff -urpN a/build/cmake/compilers.cmake b/build/cmake/compilers.cmake
---- a/build/cmake/compilers.cmake 2019-03-11 22:52:18.000000000 +0100
-+++ b/build/cmake/compilers.cmake 2019-05-12 18:04:11.045296059 +0200
-@@ -14,8 +14,8 @@
-
- if(CMAKE_COMPILER_IS_GNUCXX OR "${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang") # AND NOT MINGW??
-
-- target_compile_options(nana PRIVATE -Wall
-- PUBLIC -g )
-+ target_compile_options(nana PRIVATE -Wall
-+ PUBLIC -Os -s)
-
- set(THREADS_PREFER_PTHREAD_FLAG ON) # todo - test this
- find_package(Threads REQUIRED)
-diff -urpN a/build/cmake/enable_audio.cmake b/build/cmake/enable_audio.cmake
---- a/build/cmake/enable_audio.cmake 2019-03-11 22:52:18.000000000 +0100
-+++ b/build/cmake/enable_audio.cmake 2019-05-16 07:08:35.652372215 +0200
+diff -urpN nana.orig/build/cmake/enable_audio.cmake nana/build/cmake/enable_audio.cmake
+--- nana.orig/build/cmake/enable_audio.cmake 2019-10-05 08:13:02.018317259 +0200
++++ nana/build/cmake/enable_audio.cmake 2019-10-05 08:14:23.775572475 +0200
@@ -4,12 +4,12 @@ option(NANA_CMAKE_ENABLE_AUDIO "Enable c
if(NANA_CMAKE_ENABLE_AUDIO)
target_compile_definitions(nana PUBLIC NANA_ENABLE_AUDIO)
@@ -44,10 +31,10 @@ diff -urpN a/build/cmake/enable_audio.cmake b/build/cmake/enable_audio.cmake
- if(ASOUND_FOUND)
- target_include_directories(nana PUBLIC ${ASOUND_INCLUDE_DIRS})
- target_link_libraries(nana PUBLIC ${ASOUND_LIBRARIES})
-+ find_package(ALSA)
++ find_package(ALSA) # ? https://github.com/hintjens/demidi/blob/master/Findasound.cmake
+ if(ALSA_FOUND)
+ target_include_directories(nana PUBLIC ${ALSA_INCLUDE_DIRS})
-+ target_link_libraries(nana PUBLIC ${ALAS_LIBRARIES})
++ target_link_libraries(nana PUBLIC ${ALSA_LIBRARIES})
else()
message(FATAL_ERROR "libasound is not found")
endif()
@@ -55,27 +42,3 @@ diff -urpN a/build/cmake/enable_audio.cmake b/build/cmake/enable_audio.cmake
-endif()
\ No newline at end of file
+endif()
-diff -urpN a/source/filesystem/filesystem.cpp b/source/filesystem/filesystem.cpp
---- a/source/filesystem/filesystem.cpp 2019-04-22 05:06:30.000000000 +0200
-+++ b/source/filesystem/filesystem.cpp 2019-05-16 07:10:08.609800194 +0200
-@@ -40,9 +40,9 @@
- #include <dirent.h>
- #include <cstdio>
- #include <cstring>
-- #include <errno.h>
-+ #include <cerrno>
- #include <unistd.h>
-- #include <stdlib.h>
-+ #include <cstdlib>
- #endif
-
- namespace fs = std::filesystem;
-@@ -1141,7 +1141,7 @@ namespace nana { namespace experimental
- struct tm t;
- nana::filesystem_ext::modified_file_time(p, t);
- std::chrono::system_clock::time_point dateTime =std::chrono::system_clock::from_time_t( mktime(&t) );
-- return dateTime;
-+ return dateTime;
- }
-
- bool create_directory(const path& p)