summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChad Voegele2015-07-07 20:59:08 -0700
committerChad Voegele2015-07-07 20:59:08 -0700
commit17f88511245b112f9fcbb6552838335efdf01caf (patch)
tree4aca24e3e2f491405e9e510666ba6f183adae4ec
downloadaur-17f88511245b112f9fcbb6552838335efdf01caf.tar.gz
Initial import
-rw-r--r--.AURINFO22
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD62
-rw-r--r--n2tAssembler.desktop7
-rw-r--r--n2tAssembler.run4
-rw-r--r--n2tCPUEmulator.desktop7
-rw-r--r--n2tCPUEmulator.run4
-rw-r--r--n2tHardwareSimulator.desktop7
-rw-r--r--n2tHardwareSimulator.run4
-rw-r--r--n2tJackCompiler.run4
-rw-r--r--n2tVMEmulator.desktop7
-rw-r--r--n2tVMEmulator.run4
12 files changed, 164 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..cc616977cbb2
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,22 @@
+pkgbase = nand2tetris
+ pkgdesc = Software suite accompanying Nand2Tetris course.
+ pkgver = 2.5
+ pkgrel = 3
+ url = http://www.nand2tetris.org/
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = java-runtime
+ source = http://www.nand2tetris.org/software/nand2tetris.zip
+ source = n2tCPUEmulator.run
+ source = n2tVMEmulator.run
+ source = n2tJackCompiler.run
+ source = n2tHardwareSimulator.run
+ source = n2tAssembler.run
+ source = n2tCPUEmulator.desktop
+ source = n2tVMEmulator.desktop
+ source = n2tHardwareSimulator.desktop
+ source = n2tAssembler.desktop
+
+pkgname = nand2tetris
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d304e765d8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = nand2tetris
+ pkgdesc = Software suite accompanying Nand2Tetris course.
+ pkgver = 2.5
+ pkgrel = 3
+ url = http://www.nand2tetris.org/
+ arch = any
+ license = GPL
+ makedepends = unzip
+ depends = java-runtime
+ source = http://www.nand2tetris.org/software/nand2tetris.zip
+ source = n2tCPUEmulator.run
+ source = n2tVMEmulator.run
+ source = n2tJackCompiler.run
+ source = n2tHardwareSimulator.run
+ source = n2tAssembler.run
+ source = n2tCPUEmulator.desktop
+ source = n2tVMEmulator.desktop
+ source = n2tHardwareSimulator.desktop
+ source = n2tAssembler.desktop
+ md5sums = 1e8c2c77698fddfe570f214db56b7666
+ md5sums = 9c06f1ca0a0323638a7523f0d4dd85a3
+ md5sums = 99d421df02cb61b735c998e524889ca6
+ md5sums = f2d16dd061e09dcc128e944ba74da237
+ md5sums = 19d7f3c833d2e689c122729151ba2e02
+ md5sums = 06a58b051ef4cf27372ae92f1540a6f5
+ md5sums = 3170c0923d01e8f70378d668ac8a2eed
+ md5sums = be9557bc67ba66c63f565bfcf35f2550
+ md5sums = fa26bd9b1d54bf67c357d560b0b545bc
+ md5sums = abf1c846bf3e9216bfaaea0acc0478f1
+
+pkgname = nand2tetris
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db63c394b4e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# $Id$
+# Contributor: Chad Voegele <cavoegele@gmail.com>
+
+pkgname=nand2tetris
+pkgver=2.5
+pkgrel=3
+pkgdesc="Software suite accompanying Nand2Tetris course."
+arch=('any')
+url="http://www.nand2tetris.org/"
+license=('GPL')
+depends=('java-runtime')
+makedepends=('unzip')
+source=(http://www.nand2tetris.org/software/nand2tetris.zip
+ n2tCPUEmulator.run
+ n2tVMEmulator.run
+ n2tJackCompiler.run
+ n2tHardwareSimulator.run
+ n2tAssembler.run
+ n2tCPUEmulator.desktop
+ n2tVMEmulator.desktop
+ n2tHardwareSimulator.desktop
+ n2tAssembler.desktop
+)
+md5sums=('1e8c2c77698fddfe570f214db56b7666'
+ '9c06f1ca0a0323638a7523f0d4dd85a3'
+ '99d421df02cb61b735c998e524889ca6'
+ 'f2d16dd061e09dcc128e944ba74da237'
+ '19d7f3c833d2e689c122729151ba2e02'
+ '06a58b051ef4cf27372ae92f1540a6f5'
+ '3170c0923d01e8f70378d668ac8a2eed'
+ 'be9557bc67ba66c63f565bfcf35f2550'
+ 'fa26bd9b1d54bf67c357d560b0b545bc'
+ 'abf1c846bf3e9216bfaaea0acc0478f1')
+
+package() {
+ cd ${srcdir}/${pkgname}
+
+ # just install tools directory
+ cd tools
+ for file in $(find . -type f -name "*.sh"); do
+ install -Dm755 $file ${pkgdir}/usr/share/${pkgname}/$file
+ done
+
+ for file in $(find bin builtInVMCode builtInChips OS\
+ -name "*.jar"\
+ -or -name "*.html"\
+ -or -name "*.txt"\
+ -or -name "*.vm"\
+ -or -name "*.gif"\
+ -or -name "*.hdl"\
+ -or -name "*.class"); do
+ install -Dm644 $file ${pkgdir}/usr/share/${pkgname}/$file
+ done
+
+ for file in $(find ${srcdir} -name "*.run"); do
+ install -Dm755 $file ${pkgdir}/usr/bin/$(basename ${file%.*})
+ done
+
+ for file in $(find ${srcdir} -name "*.desktop"); do
+ install -Dm644 $file ${pkgdir}/usr/share/applications/${file}
+ done
+}
diff --git a/n2tAssembler.desktop b/n2tAssembler.desktop
new file mode 100644
index 000000000000..86f0a730bb08
--- /dev/null
+++ b/n2tAssembler.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=nand2tetris Assembler
+Comment=Translates programs from the Hack assembly language to Hack binary code.
+Exec=n2tAssembler
+Icon=java
+Categories=Education;
diff --git a/n2tAssembler.run b/n2tAssembler.run
new file mode 100644
index 000000000000..4c8c07b6c4f9
--- /dev/null
+++ b/n2tAssembler.run
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/nand2tetris
+exec ./Assembler.sh $@
diff --git a/n2tCPUEmulator.desktop b/n2tCPUEmulator.desktop
new file mode 100644
index 000000000000..46b59284b35d
--- /dev/null
+++ b/n2tCPUEmulator.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=nand2tetris CPU Emulator
+Comment=Emulates the operation of the Hack computer system.
+Exec=n2tCPUEmulator
+Icon=java
+Categories=Education;
diff --git a/n2tCPUEmulator.run b/n2tCPUEmulator.run
new file mode 100644
index 000000000000..c7bb38c9adc7
--- /dev/null
+++ b/n2tCPUEmulator.run
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/nand2tetris
+exec ./CPUEmulator.sh $@
diff --git a/n2tHardwareSimulator.desktop b/n2tHardwareSimulator.desktop
new file mode 100644
index 000000000000..eaae298e77cf
--- /dev/null
+++ b/n2tHardwareSimulator.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=nand2tetris Hardware Simulator
+Comment=Simulates and tests logic gates and chips implemented in HDL.
+Exec=n2tHardwareSimulator
+Icon=java
+Categories=Education;
diff --git a/n2tHardwareSimulator.run b/n2tHardwareSimulator.run
new file mode 100644
index 000000000000..cc0f24d67b1f
--- /dev/null
+++ b/n2tHardwareSimulator.run
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/nand2tetris
+exec ./HardwareSimulator.sh $@
diff --git a/n2tJackCompiler.run b/n2tJackCompiler.run
new file mode 100644
index 000000000000..60913a1458fd
--- /dev/null
+++ b/n2tJackCompiler.run
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/nand2tetris
+exec ./JackCompiler.sh $@
diff --git a/n2tVMEmulator.desktop b/n2tVMEmulator.desktop
new file mode 100644
index 000000000000..d2589f04acb8
--- /dev/null
+++ b/n2tVMEmulator.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=nand2tetris VM Emulator
+Comment=Emulates the operation of the virtual machine for Hack.
+Exec=n2tVMEmulator
+Icon=java
+Categories=Education;
diff --git a/n2tVMEmulator.run b/n2tVMEmulator.run
new file mode 100644
index 000000000000..ac7b877ff9b4
--- /dev/null
+++ b/n2tVMEmulator.run
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/nand2tetris
+exec ./VMEmulator.sh $@