summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2019-01-24 15:09:33 -0500
committerLeo P2019-01-24 15:09:33 -0500
commit1abf7c8f2da9005b4697671e5a2476cd4bbc01b6 (patch)
treeff9c8a8aaab4d0d35db4be804e2607a5f296f318
parente2232179bc746955c927c52d23f5683faad5a77f (diff)
downloadaur-1abf7c8f2da9005b4697671e5a2476cd4bbc01b6.tar.gz
version bump, boost 1.69 compatibility
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--boost-1.69.patch32
3 files changed, 48 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff58d4210ef9..f06faa097e73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Jan 2 22:44:00 UTC 2019
pkgbase = nanocurrency
pkgdesc = Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees.
- pkgver = 17.0
+ pkgver = 17.1
pkgrel = 1
url = https://nano.org/
install = install
@@ -11,8 +9,8 @@ pkgbase = nanocurrency
license = BSD 2-clause
makedepends = cmake
depends = qt5-base
- depends = boost>=1.66.0
- depends = boost-libs>=1.66.0
+ depends = boost>=1.69.0
+ depends = boost-libs>=1.69.0
provides = raiblocks
provides = nanocurrency
conflicts = raiblocks
@@ -22,7 +20,8 @@ pkgbase = nanocurrency
source = nanowallet.desktop
source = nanowallet128.png
source = nano-node.service
- source = git+https://github.com/nanocurrency/nano-node.git#tag=V17.0
+ source = boost-1.69.patch
+ source = git+https://github.com/nanocurrency/nano-node.git#tag=V17.1
source = git+https://github.com/weidai11/cryptopp.git
source = git+https://github.com/nanocurrency/lmdb.git#branch=lmdb_0_9_21
source = git+https://github.com/miniupnp/miniupnp.git
@@ -30,6 +29,7 @@ pkgbase = nanocurrency
sha256sums = 6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91
sha256sums = 27179351dbc3e000d54b5b13f0c2326b4c4bd06e93b1d0b2ea1849609aeadc2e
sha256sums = c219c91db98f33097e7d96ef0f0c95e4b9d6226ac2ab90e30be7f955c43bfa35
+ sha256sums = 64b3be81b0616120be239a01ad12971277a6fbb4d1b07eb00580c3c10c0f5880
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index db4e75bf1c14..074d1e823e05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=nanocurrency
-pkgver=17.0
+pkgver=17.1
_tag="V$pkgver"
pkgrel=1
pkgdesc="Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
@@ -7,7 +7,7 @@ arch=('i686' 'x86_64')
url="https://nano.org/"
license=('BSD 2-clause')
makedepends=('cmake')
-depends=('qt5-base' 'boost>=1.66.0' 'boost-libs>=1.66.0')
+depends=('qt5-base' 'boost>=1.69.0' 'boost-libs>=1.69.0')
provides=(raiblocks nanocurrency)
conflicts=("raiblocks" "raiblocks-git" "raiblocks-node-git" "nanocurrency-node-git")
install=install
@@ -15,6 +15,7 @@ install=install
source=(nanowallet.desktop
nanowallet128.png
nano-node.service
+ boost-1.69.patch
"git+https://github.com/nanocurrency/nano-node.git#tag=${_tag}"
git+https://github.com/weidai11/cryptopp.git
"git+https://github.com/nanocurrency/lmdb.git#branch=lmdb_0_9_21"
@@ -24,6 +25,7 @@ source=(nanowallet.desktop
sha256sums=('6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91'
'27179351dbc3e000d54b5b13f0c2326b4c4bd06e93b1d0b2ea1849609aeadc2e'
'c219c91db98f33097e7d96ef0f0c95e4b9d6226ac2ab90e30be7f955c43bfa35'
+ '64b3be81b0616120be239a01ad12971277a6fbb4d1b07eb00580c3c10c0f5880'
'SKIP'
'SKIP'
'SKIP'
@@ -32,6 +34,12 @@ sha256sums=('6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91'
prepare() {
cd "$srcdir/nano-node"
+
+
+ if `grep Boost::system ./rai/node/CMakeLists.txt -q`; then
+ echo "patching for Boost 1.69 compatibility"
+ patch -p1 < $srcdir/boost-1.69.patch
+ fi
git submodule init
diff --git a/boost-1.69.patch b/boost-1.69.patch
new file mode 100644
index 000000000000..7d6cbcf4d5a1
--- /dev/null
+++ b/boost-1.69.patch
@@ -0,0 +1,32 @@
+---
+ rai/node/CMakeLists.txt | 1 -
+ rai/secure/CMakeLists.txt | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/rai/node/CMakeLists.txt b/rai/node/CMakeLists.txt
+index 86da82d4..ef7bd9be 100644
+--- a/rai/node/CMakeLists.txt
++++ b/rai/node/CMakeLists.txt
+@@ -60,7 +60,6 @@ target_link_libraries (node
+ Boost::log
+ Boost::log_setup
+ Boost::program_options
+- Boost::system
+ Boost::thread
+ Boost::boost
+ ${CMAKE_DL_LIBS}
+diff --git a/rai/secure/CMakeLists.txt b/rai/secure/CMakeLists.txt
+index 38f4385c..2c7340a8 100644
+--- a/rai/secure/CMakeLists.txt
++++ b/rai/secure/CMakeLists.txt
+@@ -44,7 +44,6 @@ target_link_libraries(secure
+ rai_lib
+ lmdb
+ Boost::boost
+- Boost::system
+ Boost::filesystem)
+
+ target_compile_definitions(secure PUBLIC
+--
+2.20.1
+