summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2018-01-01 20:06:44 -0500
committerLeo P2018-01-01 20:06:44 -0500
commitbce9ed61bce0ae687b63263554b1f7533fe4a6f1 (patch)
treece6ff131c5bacabe4d81860617a27db5831f75b9
parente4f019255ae7bc6fb8f86baf173666126497f117 (diff)
downloadaur-bce9ed61bce0ae687b63263554b1f7533fe4a6f1.tar.gz
add optimization sensing
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f165580b8c5f..ab30d6ca46e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Dec 20 19:44:33 UTC 2017
+# Mon Jan 1 23:55:50 UTC 2018
pkgbase = raiblocks-git
pkgdesc = RaiBlocks is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees.
- pkgver = 9.0.r13.g957386c1
- pkgrel = 1
+ pkgver = 9.0.r56.ga80a9c0d
+ pkgrel = 2
url = http://raiblocks.com/
install = install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 3984ba6f93c3..9591f9bb6cc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=raiblocks-git
-pkgver=9.0.r13.g957386c1
-pkgrel=1
+pkgver=9.0.r56.ga80a9c0d
+pkgrel=2
pkgdesc="RaiBlocks is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
arch=('i686' 'x86_64')
url="http://raiblocks.com/"
@@ -46,13 +46,24 @@ prepare() {
git submodule sync lmdb
git submodule update
- if grep avx2 /proc/cpuinfo; then
- echo "build with AVX2 optimizations"
- cmake -D RAIBLOCKS_GUI=ON -D ENABLE_AVX2=ON -D PERMUTE_WITH_GATHER=ON -D PERMUTE_WITH_SHUFFLES=ON ./
+ #if grep sse4 /proc/cpuinfo; then
+
+ _flags=( "-D RAIBLOCKS_GUI=ON" )
+
+ if grep -q avx2 /proc/cpuinfo; then
+ echo "using AVX2 optimizations"
+ _flags+=( "-D ENABLE_AVX2=ON" "-D PERMUTE_WITH_GATHER=ON" "-D PERMUTE_WITH_SHUFFLES=ON" )
else
- echo "build without AVX2 optimizations"
- cmake -D RAIBLOCKS_GUI=ON ./
+ echo "excluding unsupported AVX2 optimizations"
fi
+ if grep -q sse4 /proc/cpuinfo; then
+ echo "build with SIMD optimizations"
+ _flags+=( "-D RAIBLOCKS_SIMD_OPTIMIZATIONS=ON" )
+ else
+ echo "excluding unsupported SIMD optimizations"
+ _flags+=( "-D RAIBLOCKS_SIMD_OPTIMIZATIONS=OFF" )
+ fi
+ cmake $_flags ./
}
build() {