summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroweissbarth2022-01-05 15:38:20 +0100
committeroweissbarth2022-01-05 15:38:20 +0100
commitea08a28be53fd72a10b5c8dae84572f9baaa2746 (patch)
treedc251554b5afb731e2f8917a1b265cf1cdbf171f
parent20b7360f84c6379ca615664552be4625e9ee4c4b (diff)
downloadaur-ea08a28be53fd72a10b5c8dae84572f9baaa2746.tar.gz
now using the more up-to-date version at github.com/mitsuba-renderer/nanogui
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a74792546c3..b8c73a6f0d4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = nanogui-git
- pkgdesc = NanoGUI is a minimalistic cross-platform widget library for OpenGL 3.x or higher.
+ pkgdesc = A minimalistic cross-platform widget library for OpenGL 3+, GLES 2/3, and Metal
pkgver = r344.f9c3b7a
pkgrel = 1
- url = https://github.com/wjakob/nanogui
+ url = https://github.com/mitsuba-renderer/nanogui
arch = x86_64
license = BSD
makedepends = git
makedepends = cmake
makedepends = make
- depends = eigen
depends = glfw
- depends = nanovg
- depends = pybind11
+ depends = python
provides = nanogui
conflicts = nanogui
- source = nanogui::git+https://github.com/wjakob/nanogui
+ source = nanogui::git+https://github.com/mitsuba-renderer/nanogui
md5sums = SKIP
pkgname = nanogui-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bb6ff376bed9..3454a74c8837 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Oliver Weissbarth <mail@oweissbarth.de>
pkgname=nanogui-git
-pkgver=r344.f9c3b7a
+pkgver=r525.ef1f258
pkgrel=1
-pkgdesc="NanoGUI is a minimalistic cross-platform widget library for OpenGL 3.x or higher."
+pkgdesc="A minimalistic cross-platform widget library for OpenGL 3+, GLES 2/3, and Metal"
arch=("x86_64")
-url="https://github.com/wjakob/nanogui"
+url="https://github.com/mitsuba-renderer/nanogui"
license=('BSD')
groups=()
-depends=('eigen' 'glfw' 'nanovg' 'pybind11')
+depends=('glfw' 'python')
makedepends=('git' 'cmake' 'make')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
backup=()
options=()
-source=('nanogui::git+https://github.com/wjakob/nanogui')
+source=("nanogui::git+https://github.com/mitsuba-renderer/${pkgname%-git}")
noextract=()
md5sums=('SKIP')
@@ -25,17 +25,18 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
- git submodule update --init --recursive
+ git submodule update --init --recursive
+ sed -i "3i include(CMakePackageConfigHelpers)" CMakeLists.txt
}
build() {
cd "$srcdir/${pkgname%-git}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DNANOGUI_BUILD_EXAMPLES=OFF -DNANOGUI_BUILD_GLFW=OFF
make
}
package() {
cd "$srcdir/${pkgname%-git}"
make DESTDIR="$pkgdir/" install
- install -D LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE.txt.
+ install -D LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE.txt
}