summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdvinAlvarado2021-07-10 09:39:55 -0700
committerEdvinAlvarado2021-07-10 09:39:55 -0700
commit62e4325aa43d2ff2fc03b594103b847d534050d9 (patch)
tree2a99889605b161c6271e21dea6b13b56e7b6d699
parentb7a7f277aab1650c75f78ac93fa488635da4ed1b (diff)
downloadaur-62e4325aa43d2ff2fc03b594103b847d534050d9.tar.gz
v3.3.7 update. fixed nanominer not receiving configs commands
-rw-r--r--PKGBUILD9
-rw-r--r--nanominer.install2
2 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 684cda482bdc..f6ea7154fd0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Edvin Alvarado <ealvarado301 g-mail>
pkgname=nanominer
-pkgver=3.3.6
+pkgver=3.3.7
pkgrel=1
pkgdesc="nanopool mining software"
arch=('any')
license=('custom:nanopool')
install=$pkgname.install
url='https://github.com/nanopool/nanominer/releases'
-sha256sums=("df4342a8e5a4ab813a3c6941e6f286be698fe14751f36c8fc1170ca68c88971c"
+sha256sums=("bbc1ee4fc3b4fa17de1a6c476a781474435f2ffefcec8fcb99e45a55e1e446b1"
"SKIP")
prepare() {
cd $pkgname-linux-$pkgver
- # saves config files in config_examples
+ # copies config files in config_examples
mkdir -p config_examples
for FILE in config*.ini
do
@@ -40,12 +40,13 @@ source=("https://github.com/nanopool/$pkgname/releases/download/v$pkgver/$pkgnam
package() {
# Launcher
- echo -e "#\!/bin/bash\ncd /opt/nanominer\nexec /opt/$pkgname/nanominer $*" > nanominer.sh
+ echo -e "#\!/bin/bash\ncd /opt/nanominer\nexec /opt/$pkgname/nanominer \$*" > nanominer.sh
install -Dm755 nanominer.sh "$pkgdir"/usr/bin/nanominer
# License
install -Dm644 Terms%20of%20Use%20Nanominer.pdf "$pkgdir"/usr/share/licenses/"$pkgname"/TOU_Nanominer.pdf
+ # Install
mkdir -p $pkgdir/opt/"$pkgname"
cp -R "$pkgname-linux-$pkgver"/* $pkgdir/opt/"$pkgname"
}
diff --git a/nanominer.install b/nanominer.install
index a7cdc4032132..5d68c9dd29ee 100644
--- a/nanominer.install
+++ b/nanominer.install
@@ -1,6 +1,6 @@
post_install () {
echo "existing config*.ini files are maintained."
- echo "If no existing config*.ini exists, it will include the src file ones."
+ # echo "If no existing config*.ini exists, it will include the src file ones."
echo "Remember to change the address in the config files to yours"
echo "find examples in /opt/nanominer/config_examples/"
}