summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-02 10:09:18 +1300
committercaltlgin2020-11-02 10:09:18 +1300
commit9428e7aafc52c249296288d2a5c44872256c23b4 (patch)
tree9aad5fc462092790c89d03414e757a8f2aaa0a43
parentd7c73087c578348732a1329ee084620cca704a74 (diff)
downloadaur-9428e7aafc52c249296288d2a5c44872256c23b4.tar.gz
Add makedepends=('extra-cmake-modules' 'qt5-tools')
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89556f0b0ce5..d57ef2203aba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = nanonote
pkgdesc = Minimalist note taking application
pkgver = 1.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/agateau/nanonote
arch = x86_64
license = BSD
- makedepends = cmake
+ makedepends = extra-cmake-modules
makedepends = git
makedepends = python-jinja
makedepends = python-pyaml
+ makedepends = qt5-tools
depends = hicolor-icon-theme
depends = qt5-base
source = git+https://github.com/agateau/nanonote.git#tag=1.3.0
diff --git a/PKGBUILD b/PKGBUILD
index 1a36d187faac..50186759bed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname='nanonote'
pkgver=1.3.0
-pkgrel=2
-pkgdesc='Minimalist note taking application '
+pkgrel=3
+pkgdesc='Minimalist note taking application'
arch=('x86_64')
url='https://github.com/agateau/nanonote'
license=('BSD')
depends=('hicolor-icon-theme' 'qt5-base')
-makedepends=('cmake' 'git' 'python-jinja' 'python-pyaml')
+makedepends=('extra-cmake-modules' 'git' 'python-jinja' 'python-pyaml' 'qt5-tools')
source=("git+${url}.git#tag=${pkgver}"
"git+${url%/*}/qpropgen.git"
"git+https://github.com/itay-grudev/SingleApplication.git")
@@ -18,26 +18,27 @@ sha256sums=('SKIP'
prepare() {
cd "${pkgname}"
+ # Submodule list: https://github.com/agateau/nanonote/raw/master/.gitmodules
git submodule init
- git config submodule.qpropgen.url "${srcdir}/qpropgen"
- git config submodule.singleapplication.url "${srcdir}/SingleApplication"
+ git config 'submodule.qpropgen.url' "${srcdir}/qpropgen"
+ git config 'submodule.singleapplication.url' "${srcdir}/SingleApplication"
git submodule update
}
build() {
export CFLAGS+=" ${CPPFLAGS}"
export CXXFLAGS+=" ${CPPFLAGS}"
- cmake -B build -S "${pkgname}" \
+ cmake -B 'build' -S "${pkgname}" \
-DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-Wno-dev
- make -C build
+ make -C 'build'
}
package() {
- make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}/README.md"
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgname}/LICENSE"
+ make DESTDIR="${pkgdir}" PREFIX='/usr' -C 'build' install
+ install -Dvm644 "${pkgname}/README.md" -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 "${pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: