summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-05 07:45:29 +1300
committercaltlgin2020-10-05 07:45:29 +1300
commitc999ec363568ea0dbd669eb0ca9fbb23a1f5aa93 (patch)
tree67b71f05b37938c2e9027645f23d07d424a8f10c
downloadaur-c999ec363568ea0dbd669eb0ca9fbb23a1f5aa93.tar.gz
Add to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f545e8b0549
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nanonote
+ pkgdesc = Minimalist note taking application
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/agateau/nanonote
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ makedepends = python-jinja
+ makedepends = python-pyaml
+ depends = hicolor-icon-theme
+ depends = qt5-base
+ source = git+https://github.com/agateau/nanonote.git#tag=1.3.0
+ sha256sums = SKIP
+
+pkgname = nanonote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0ac7748e1eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='nanonote'
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='Minimalist note taking application '
+arch=('x86_64')
+url='https://github.com/agateau/nanonote'
+license=('BSD')
+depends=('hicolor-icon-theme' 'qt5-base')
+makedepends=('cmake' 'python-jinja' 'python-pyaml')
+source=("git+${url}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${pkgname}"
+ git submodule update --init
+}
+
+build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B build -S "${pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${pkgname}/README.md"
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: