summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-05 10:10:52 +1300
committercaltlgin2020-10-05 10:10:52 +1300
commitd7c73087c578348732a1329ee084620cca704a74 (patch)
tree454d764d875ecddae5f21f7dd812b022f314511f
parent89b885bde0a02f2ea00d32b2178de88631620894 (diff)
downloadaur-d7c73087c578348732a1329ee084620cca704a74.tar.gz
Add git submodules to source array
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 353b128f5145..89556f0b0ce5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nanonote
pkgdesc = Minimalist note taking application
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/agateau/nanonote
arch = x86_64
license = BSD
@@ -12,6 +12,10 @@ pkgbase = nanonote
depends = hicolor-icon-theme
depends = qt5-base
source = git+https://github.com/agateau/nanonote.git#tag=1.3.0
+ source = git+https://github.com/agateau/qpropgen.git
+ source = git+https://github.com/itay-grudev/SingleApplication.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = nanonote
diff --git a/PKGBUILD b/PKGBUILD
index a0bceb8e750a..1a36d187faac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,26 @@
pkgname='nanonote'
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='Minimalist note taking application '
arch=('x86_64')
url='https://github.com/agateau/nanonote'
license=('BSD')
depends=('hicolor-icon-theme' 'qt5-base')
makedepends=('cmake' 'git' 'python-jinja' 'python-pyaml')
-source=("git+${url}.git#tag=${pkgver}")
-sha256sums=('SKIP')
+source=("git+${url}.git#tag=${pkgver}"
+ "git+${url%/*}/qpropgen.git"
+ "git+https://github.com/itay-grudev/SingleApplication.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
cd "${pkgname}"
- git submodule update --init
+ git submodule init
+ git config submodule.qpropgen.url "${srcdir}/qpropgen"
+ git config submodule.singleapplication.url "${srcdir}/SingleApplication"
+ git submodule update
}
build() {