summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-02 10:09:55 +1300
committercaltlgin2020-11-02 10:09:55 +1300
commitcbedb977a49e7c2308211991d13c1e5e0cdd7972 (patch)
treed1110f5ee3a6780849b36d4caf3f4fb5a7e08ccb
parentd7cf07426411a75f4ae511e446fe73a44a015c6d (diff)
downloadaur-nanonote-git.tar.gz
Add makedepends=('extra-cmake-modules' 'qt5-tools')
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea77f5163a90..0e89fd32e191 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = nanonote-git
pkgdesc = Minimalist note taking application
pkgver = 1.3.0.r0.g7230986
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/agateau/nanonote
arch = x86_64
license = BSD
- makedepends = cmake
+ makedepends = extra-cmake-modules
makedepends = git
makedepends = python-jinja
makedepends = python-pyaml
+ makedepends = qt5-tools
depends = hicolor-icon-theme
depends = qt5-base
provides = nanonote
diff --git a/PKGBUILD b/PKGBUILD
index 6c22abfdf940..54816be4854a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,28 @@
_pkgname='nanonote'
pkgname="${_pkgname}-git"
pkgver=1.3.0.r0.g7230986
-pkgrel=1
-pkgdesc='Minimalist note taking application '
+pkgrel=2
+pkgdesc='Minimalist note taking application'
arch=('x86_64')
url='https://github.com/agateau/nanonote'
license=('BSD')
depends=('hicolor-icon-theme' 'qt5-base')
-makedepends=('cmake' 'git' 'python-jinja' 'python-pyaml')
+makedepends=('extra-cmake-modules' 'git' 'python-jinja' 'python-pyaml' 'qt5-tools')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("git+${url}.git"
"git+${url%/*}/qpropgen.git"
"git+https://github.com/itay-grudev/SingleApplication.git")
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
cd "${_pkgname}"
# Submodule list: https://github.com/agateau/nanonote/raw/master/.gitmodules
git submodule init
- git config submodule.qpropgen.url "${srcdir}/qpropgen"
- git config submodule.singleapplication.url "${srcdir}/SingleApplication"
+ git config 'submodule.qpropgen.url' "${srcdir}/qpropgen"
+ git config 'submodule.singleapplication.url' "${srcdir}/SingleApplication"
git submodule update
}
@@ -33,17 +35,17 @@ pkgver() {
build() {
export CFLAGS+=" ${CPPFLAGS}"
export CXXFLAGS+=" ${CPPFLAGS}"
- cmake -B build -S "${_pkgname}" \
+ cmake -B 'build' -S "${_pkgname}" \
-DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-Wno-dev
- make -C build
+ make -C 'build'
}
package() {
- make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${_pkgname}/README.md"
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${_pkgname}/LICENSE"
+ make DESTDIR="${pkgdir}" PREFIX='/usr' -C 'build' install
+ install -Dvm644 "${_pkgname}/README.md" -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: