summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Bartell2015-06-08 10:28:14 -0500
committerSean Bartell2015-06-08 10:28:14 -0500
commit2a412a233146a337d8c505d814a1273e5bf45184 (patch)
tree37364f1237689f7a86b013a025ae5b35c7a73509
downloadaur-2a412a233146a337d8c505d814a1273e5bf45184.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5eeaaf73c10e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nanopond
+ pkgdesc = A teeny tiny artificial life virtual machine
+ pkgver = 1.9
+ pkgrel = 1
+ url = http://adam.ierymenko.name/nanopond.shtml
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl
+ source = http://adam.ierymenko.name/files/nanopond-1.9.c
+ md5sums = ff67c936ed47de3ea4a8a6653e54aad7
+ sha512sums = c4bed6fdaa90f830434a732b0c9f9f980154c20a26af55e54d50ddf9403dc020427b9cda8d52f6c864e691a67367d1051132762f6f7211d9c9bd7925bfacdf57
+
+pkgname = nanopond
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a220e6bc32b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Sean Bartell <yotann@yotann.org>
+pkgname=nanopond
+pkgver=1.9
+pkgrel=1
+pkgdesc="A teeny tiny artificial life virtual machine"
+arch=('i686' 'x86_64')
+url="http://adam.ierymenko.name/nanopond.shtml"
+license=('GPL')
+depends=('sdl')
+source=("http://adam.ierymenko.name/files/$pkgname-$pkgver.c")
+md5sums=('ff67c936ed47de3ea4a8a6653e54aad7')
+sha512sums=('c4bed6fdaa90f830434a732b0c9f9f980154c20a26af55e54d50ddf9403dc020427b9cda8d52f6c864e691a67367d1051132762f6f7211d9c9bd7925bfacdf57')
+
+build() {
+ # These are the flags recommended in the source file
+ gcc $CFLAGS $(sdl-config --cflags --libs) \
+ -O6 -funroll-loops -fomit-frame-pointer -ftree-vectorize \
+ -o nanopond "$pkgname-$pkgver.c"
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install nanopond "$pkgdir/usr/bin"
+}