summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Capocasa2017-02-28 18:46:09 +0100
committerCarlo Capocasa2017-02-28 22:47:07 +0100
commitf715998d3499f3e61c2b8b89630b1a912af2ab7f (patch)
tree37a8afa3a5257519eeff57d57372ba2203a9453c
downloadaur-f715998d3499f3e61c2b8b89630b1a912af2ab7f.tar.gz
nanotts
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD58
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12e8a5288e22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = nanotts-git
+ pkgdesc = The Cainteoir Text-To-Speach Engine (from git)
+ pkgver = r46.2370600
+ pkgrel = 1
+ url = https://github.com/gmn/nanotts
+ arch = x86_64
+ license = GPL
+ source = nanotts-git::git+https://github.com/gmn/nanotts.git#branch=master
+ md5sums = SKIP
+
+pkgname = nanotts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..999537074863
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Carlo Capocasa <carlo@capocasa.net>
+pkgname=nanotts-git
+pkgver=r46.2370600
+pkgrel=1
+epoch=
+pkgdesc="The Cainteoir Text-To-Speach Engine (from git)"
+arch=(x86_64)
+url="https://github.com/gmn/nanotts"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+"$pkgname::git+https://github.com/gmn/nanotts.git#branch=master"
+)
+noextract=()
+md5sums=(
+"SKIP"
+)
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname"
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+check() {
+ cd "$pkgname"
+}
+
+package() {
+ dir="$pkgdir/opt/$pkgname"
+ mkdir -p "$dir"
+ cp "$pkgname/$pkgname" "$dir"
+ cp -R "$pkgname/lang" "$dir"
+ mkdir -p "$pkgdir/usr/bin"
+ cd "$pkgdir/usr/bin"
+ ln -s "../../opt/$pkgname/$pkgname"
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+