summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera Micó2024-03-10 23:40:50 +0000
committerJoan Bruguera Micó2024-03-10 23:40:50 +0000
commit19aac1cfce9da00f33ea3278fb9f90b0d2955459 (patch)
treebd72960d550d1107bfe76f003e49830b5ddf5092
parent1b7f8ed492178a6dcfde8746fec76130a30a98fa (diff)
downloadaur-nanox.tar.gz
Fix build with GCC 14
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch27
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 775897fda40b..ffad54599b57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nanox
pkgdesc = Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.
pkgver = 0.15.20190627
- pkgrel = 3
+ pkgrel = 4
url = https://pm.bsc.es/ompss
arch = x86_64
license = GPL2
@@ -11,8 +11,10 @@ pkgbase = nanox
source = https://pm.bsc.es/ftp/ompss/releases/ompss-19.06.tar.gz
source = nanox-Fix-build-due-to-Werror-sign-compare-mismatch.patch
source = nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch
+ source = nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch
sha512sums = 159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c03031e7e416090360c36a51a38da083b2b2ed4e75dda5c55a103806d91d2
sha512sums = d72f15c858309a5dbed09259e6700220c5b1d931aef9f37c9df0b9ccdf16c22b5d09f4efaab445e944f1a2dee9f5e6c8d96df34bfa765c8c47f6a212f8d168f6
sha512sums = f900d2c30236ef641e1e527364324e317d1df2746082df0e0bf8adcceb279b7cde6f0c094576e330de24fc9d51f989016f6e2d50489e308fe2f8683acb3bf41c
+ sha512sums = 46a3aebbc723771fdb54e863463321dc0f58a3f95a20b953d767f88a54768bb50f0170139dc9ad0c181be41fa1ba684edc4e15e001553f15649129ec483efccf
pkgname = nanox
diff --git a/PKGBUILD b/PKGBUILD
index 32a5c941705e..b83c3f80ab3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _bundlepkgname='ompss'
pkgdesc='Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.'
pkgver='0.15.20190627'
_bundlepkgver='19.06'
-pkgrel='3'
+pkgrel='4'
arch=('x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL2')
@@ -12,16 +12,19 @@ depends=(extrae sqlite3)
makedepends=(python)
source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz"
"nanox-Fix-build-due-to-Werror-sign-compare-mismatch.patch"
- "nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch")
+ "nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch"
+ "nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch")
sha512sums=(159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c03031e7e416090360c36a51a38da083b2b2ed4e75dda5c55a103806d91d2
d72f15c858309a5dbed09259e6700220c5b1d931aef9f37c9df0b9ccdf16c22b5d09f4efaab445e944f1a2dee9f5e6c8d96df34bfa765c8c47f6a212f8d168f6
- f900d2c30236ef641e1e527364324e317d1df2746082df0e0bf8adcceb279b7cde6f0c094576e330de24fc9d51f989016f6e2d50489e308fe2f8683acb3bf41c)
+ f900d2c30236ef641e1e527364324e317d1df2746082df0e0bf8adcceb279b7cde6f0c094576e330de24fc9d51f989016f6e2d50489e308fe2f8683acb3bf41c
+ 46a3aebbc723771fdb54e863463321dc0f58a3f95a20b953d767f88a54768bb50f0170139dc9ad0c181be41fa1ba684edc4e15e001553f15649129ec483efccf)
prepare() {
cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
patch -Np1 -i "$srcdir/nanox-Fix-build-due-to-Werror-sign-compare-mismatch.patch"
patch -Np1 -i "$srcdir/nanox-Fix-build-due-to-use-of-deprecated-_sys_siglist.patch"
+ patch -Np1 -i "$srcdir/nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch"
}
build() {
diff --git a/nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch b/nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch
new file mode 100644
index 000000000000..18e988765287
--- /dev/null
+++ b/nanox-Fix-build-due-to-Werror-template-id-cdtor-fix-GCC-14.patch
@@ -0,0 +1,27 @@
+From 619d004832ec8dee433e6f279a93f427634a1d40 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Joan=20Bruguera=20Mic=C3=B3?= <joanbrugueram@gmail.com>
+Date: Sun, 10 Mar 2024 23:16:21 +0000
+Subject: [PATCH] Fix build due to -Werror=template-id-cdtor (fix GCC 14)
+
+---
+ src/core/addressspace_decl.hpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/core/addressspace_decl.hpp b/src/core/addressspace_decl.hpp
+index 793a918..10a2976 100644
+--- a/src/core/addressspace_decl.hpp
++++ b/src/core/addressspace_decl.hpp
+@@ -172,8 +172,8 @@ class SeparateAddressSpace {
+ template <class T>
+ class MemSpace : public T {
+ public:
+- MemSpace<T>( Device &d );
+- MemSpace<T>( memory_space_id_t memSpaceId, Device &d, bool allocWide, std::size_t slabSize );
++ MemSpace( Device &d );
++ MemSpace( memory_space_id_t memSpaceId, Device &d, bool allocWide, std::size_t slabSize );
+ void copy( MemSpace< SeparateAddressSpace > &from, TransferList &list, WD const *wd, bool inval = false );
+ };
+
+--
+2.44.0
+