summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-30 13:56:32 +0100
committerJoan Bruguera2019-03-30 13:56:32 +0100
commit2c4b47c8bde149c37f291fb72d4dc072e27f8554 (patch)
tree52315a7ac5a2d04fbbdaf30adc54d07466fc4f28
downloadaur-2c4b47c8bde149c37f291fb72d4dc072e27f8554.tar.gz
Initial version.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..729f297ff2be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = nanox
+ pkgdesc = Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.
+ pkgver = 0.14.1
+ pkgrel = 1
+ url = https://pm.bsc.es/ompss
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = gcc7
+ depends = extrae
+ depends = sqlite3
+ source = https://pm.bsc.es/ftp/ompss/releases/ompss-17.12.1.tar.gz
+ sha512sums = e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
+
+pkgname = nanox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b189337ae0c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
+pkgname='nanox'
+_bundlepkgname='ompss'
+pkgdesc='Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.'
+pkgver='0.14.1'
+_bundlepkgver='17.12.1'
+pkgrel='1'
+arch=('i686' 'x86_64')
+url='https://pm.bsc.es/ompss'
+license=('GPL2')
+depends=(extrae sqlite3)
+makedepends=(gcc7)
+source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz")
+sha512sums=(e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344)
+
+# WORKAROUND: The sources are outdated according to Arch's standards,
+# so we have to downgrade/disable some things...
+export CC=gcc-7
+export CXX=g++-7
+
+build() {
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+
+ # See https://hub.docker.com/r/bscpm/ompss/dockerfile
+ ./configure \
+ --prefix=/usr \
+ --with-extrae=/usr
+
+ make
+}
+
+package() {
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}