summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-04-01 12:54:58 +0200
committerJoan Bruguera2019-04-01 12:54:58 +0200
commit7323149fce8dd68f77f1f1c09b33122219faefa6 (patch)
treec0cb18198443475476d985d420f71908f4f33d4d
parent2c4b47c8bde149c37f291fb72d4dc072e27f8554 (diff)
downloadaur-7323149fce8dd68f77f1f1c09b33122219faefa6.tar.gz
Add patches to build on GCC8.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 729f297ff2be..be90bc8fe00b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = nanox
pkgdesc = Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.
pkgver = 0.14.1
- pkgrel = 1
+ pkgrel = 2
url = https://pm.bsc.es/ompss
arch = i686
arch = x86_64
license = GPL2
- makedepends = gcc7
depends = extrae
depends = sqlite3
source = https://pm.bsc.es/ftp/ompss/releases/ompss-17.12.1.tar.gz
+ source = https://github.com/bsc-pm/nanox/commit/f17ae4a5e9dd2163fc33137d99ade488fe8c934a.patch
sha512sums = e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
+ sha512sums = 61e698326a0085fafc7353510537bc80b5e1f40c480e4cb8d07642b348eb529d4868f0b7dd0e5985a1c171cba8dd2274c81634ae1bfff7d12426610df4a8a089
pkgname = nanox
diff --git a/PKGBUILD b/PKGBUILD
index b189337ae0c3..aea2ce9556df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,22 @@ _bundlepkgname='ompss'
pkgdesc='Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.'
pkgver='0.14.1'
_bundlepkgver='17.12.1'
-pkgrel='1'
+pkgrel='2'
arch=('i686' 'x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL2')
depends=(extrae sqlite3)
-makedepends=(gcc7)
-source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz")
-sha512sums=(e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344)
+source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz"
+ "https://github.com/bsc-pm/nanox/commit/f17ae4a5e9dd2163fc33137d99ade488fe8c934a.patch")
+sha512sums=(e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
+ 61e698326a0085fafc7353510537bc80b5e1f40c480e4cb8d07642b348eb529d4868f0b7dd0e5985a1c171cba8dd2274c81634ae1bfff7d12426610df4a8a089)
-# WORKAROUND: The sources are outdated according to Arch's standards,
-# so we have to downgrade/disable some things...
-export CC=gcc-7
-export CXX=g++-7
+prepare() {
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+
+ # WORKAROUND: Needed to build in GCC8 (but was unnecessary in GCC7)
+ patch -p1 < "$srcdir/f17ae4a5e9dd2163fc33137d99ade488fe8c934a.patch"
+}
build() {
cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"