summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-12-10 21:09:10 +0100
committerJoan Bruguera2019-12-10 21:09:10 +0100
commita0d597f7839b09ad97644647fa5be52b873aadb3 (patch)
treed23f98985c6143e2396a883b9f6d480baf6b47ec
parent7926c75f3c501b67d3865642fc221be46b17ff4d (diff)
downloadaur-a0d597f7839b09ad97644647fa5be52b873aadb3.tar.gz
Upgrade tracking to the latest version. Additionally, change BSC package versioning numbers, in order to include the year in the pkgver. This is to deal with the fact that multiple, different tallbars are routinely released for the same version number. Up until now, this was handled by bumping pkgrel, but this is not the correct way to handle this, since it's not just a rebuild, but just the upstream code changed.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae17ce2b8b37..cecd11dc8139 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nanox
pkgdesc = Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.
- pkgver = 0.15
- pkgrel = 2
+ pkgver = 0.15.20190627
+ pkgrel = 1
url = https://pm.bsc.es/ompss
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8cf4750ed444..62d4e5b9d612 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname='nanox'
_bundlepkgname='ompss'
pkgdesc='Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.'
-pkgver='0.15'
+pkgver='0.15.20190627'
_bundlepkgver='19.06'
-pkgrel='2'
+pkgrel='1'
arch=('i686' 'x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL2')
@@ -14,11 +14,11 @@ source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_b
sha512sums=(159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c03031e7e416090360c36a51a38da083b2b2ed4e75dda5c55a103806d91d2)
prepare() {
- cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
}
build() {
- cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
# See https://hub.docker.com/r/bscpm/ompss/dockerfile
./configure \
@@ -29,7 +29,7 @@ build() {
}
package() {
- cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
+ cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-${pkgver%.*}"
make DESTDIR="$pkgdir/" install
}