summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Bruguera2019-06-27 21:38:37 +0200
committerJoan Bruguera2019-06-27 21:38:37 +0200
commitaa5f6965a760134371f56aee5211674dbc138ea6 (patch)
tree1d5443584244f05e0de1e73eadfc5caebb48f7f9
parent7323149fce8dd68f77f1f1c09b33122219faefa6 (diff)
downloadaur-aa5f6965a760134371f56aee5211674dbc138ea6.tar.gz
OmpSs 19.06 upgrade.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be90bc8fe00b..98f0811436c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = nanox
pkgdesc = Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.
- pkgver = 0.14.1
- pkgrel = 2
+ pkgver = 0.15
+ pkgrel = 1
url = https://pm.bsc.es/ompss
arch = i686
arch = x86_64
license = GPL2
depends = extrae
depends = sqlite3
- source = https://pm.bsc.es/ftp/ompss/releases/ompss-17.12.1.tar.gz
- source = https://github.com/bsc-pm/nanox/commit/f17ae4a5e9dd2163fc33137d99ade488fe8c934a.patch
- sha512sums = e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
- sha512sums = 61e698326a0085fafc7353510537bc80b5e1f40c480e4cb8d07642b348eb529d4868f0b7dd0e5985a1c171cba8dd2274c81634ae1bfff7d12426610df4a8a089
+ source = https://pm.bsc.es/ftp/ompss/releases/ompss-19.06.tar.gz
+ sha512sums = 159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c03031e7e416090360c36a51a38da083b2b2ed4e75dda5c55a103806d91d2
pkgname = nanox
diff --git a/PKGBUILD b/PKGBUILD
index aea2ce9556df..79a4a1d87151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,18 @@
pkgname='nanox'
_bundlepkgname='ompss'
pkgdesc='Nanos++ is a runtime designed to serve as runtime support in parallel environments. It is mainly used to support OmpSs, a extension to OpenMP developed at BSC.'
-pkgver='0.14.1'
-_bundlepkgver='17.12.1'
-pkgrel='2'
+pkgver='0.15'
+_bundlepkgver='19.06'
+pkgrel='1'
arch=('i686' 'x86_64')
url='https://pm.bsc.es/ompss'
license=('GPL2')
depends=(extrae sqlite3)
-source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz"
- "https://github.com/bsc-pm/nanox/commit/f17ae4a5e9dd2163fc33137d99ade488fe8c934a.patch")
-sha512sums=(e68effb54b3a4e91da22808a928afcd586d41a3825ec2cea1f783a65d4e075cfb07ce3f5a8006c5a204a46f37fc73383cd549f6706ed12124724b6be18520344
- 61e698326a0085fafc7353510537bc80b5e1f40c480e4cb8d07642b348eb529d4868f0b7dd0e5985a1c171cba8dd2274c81634ae1bfff7d12426610df4a8a089)
+source=("https://pm.bsc.es/ftp/${_bundlepkgname}/releases/${_bundlepkgname}-${_bundlepkgver}.tar.gz")
+sha512sums=(159efc17ba446f3f2205a8c0580ed10fab263f8bdb7306d5444d1fc6a592f80d749c03031e7e416090360c36a51a38da083b2b2ed4e75dda5c55a103806d91d2)
prepare() {
cd "$srcdir/${_bundlepkgname}-${_bundlepkgver}/$pkgname-$pkgver"
-
- # WORKAROUND: Needed to build in GCC8 (but was unnecessary in GCC7)
- patch -p1 < "$srcdir/f17ae4a5e9dd2163fc33137d99ade488fe8c934a.patch"
}
build() {