summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Gaifas2021-12-14 19:02:40 +0100
committerLorenzo Gaifas2021-12-14 19:02:40 +0100
commit1cf919f4ed32bc00329905622dfb4a72750897ed (patch)
tree65ab521ec799166e8947ee85b4164da9206c5e8b
downloadaur-1cf919f4ed32bc00329905622dfb4a72750897ed.tar.gz
first build
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f43338626f2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = napari-console
+ pkgdesc = A plugin that adds a console to napari.
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/napari/napari-console
+ arch = any
+ license = BSD
+ makedepends = python-setuptools-scm
+ depends = python
+ depends = python-ipykernel
+ depends = ipython
+ depends = python-qtconsole
+ depends = python-qtpy
+ provides = python-napari-console
+ source = https://files.pythonhosted.org/packages/source/n/napari-console/napari-console-0.0.4.tar.gz
+ sha256sums = ea0e30fbfdd76542adda44be457f1306a65146fe7578f95838e28d62874f4c45
+
+pkgname = napari-console
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9332b8dcae6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Lorenzo Gaifas <brisvag at gmail dot com>
+
+_name='napari-console'
+_author='napari'
+pkgname="${_name}"
+pkgver=0.0.4
+pkgrel=1
+pkgdesc='A plugin that adds a console to napari.'
+arch=('any')
+url="https://github.com/${_author}/${_name}"
+license=('BSD')
+makedepends=(
+ 'python-setuptools-scm'
+)
+depends=(
+ 'python'
+ 'python-ipykernel'
+ 'ipython'
+ 'python-qtconsole'
+ 'python-qtpy'
+)
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('ea0e30fbfdd76542adda44be457f1306a65146fe7578f95838e28d62874f4c45')
+provides=("python-${_name}")
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+}
+
+# vim:set ts=2 sw=2 et:<Paste>