summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRamadan Ali (alicavus)2023-07-07 16:04:21 +0300
committerRamadan Ali (alicavus)2023-07-07 16:04:21 +0300
commitc49c94b2e8c8f7728a7336f1f42a370a5ece64bd (patch)
treef254e29e4530b40c845bc02ceed11a8547372470
downloadaur-c49c94b2e8c8f7728a7336f1f42a370a5ece64bd.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..417f4586a1dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = naps2-bin
+ pkgdesc = NAPS2 - Not Another PDF Scanner. Scan documents to PDF and more, as simply as possible.
+ pkgver = 7.0.8
+ pkgrel = 1
+ url = https://www.naps2.com
+ arch = x86_64
+ license = GPL2
+ depends = sane
+ optdepends = sane-airscan: airscan support
+ options = !strip
+ source_x86_64 = https://github.com/cyanfish/naps2/releases/download/v7.0b8/naps2-7.0b8-linux-x64.deb
+ b2sums_x86_64 = 54f953cb8a7994a3e29fbcf97723d672b9356aa650f11581a9d10b4a0ce96dfefad07e75959bb2d880422f2e14de1d4eec7203acc94b56449d3c208086fc0298
+
+pkgname = naps2-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e32abfa01ebe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Ramadan Ali (alicavus) <rot13: ezqa@ezqa.ny>
+
+pkgname=naps2-bin
+pkgver=7.0.8
+pkgrel=1
+pkgdesc="NAPS2 - Not Another PDF Scanner. Scan documents to PDF and more, as simply as possible."
+arch=(x86_64)
+url="https://www.naps2.com"
+license=(GPL2)
+depends=(sane)
+optdepends=(
+ 'sane-airscan: airscan support'
+)
+options=(!strip)
+source_x86_64=("https://github.com/cyanfish/naps2/releases/download/v7.0b8/naps2-7.0b8-linux-x64.deb")
+b2sums_x86_64=('54f953cb8a7994a3e29fbcf97723d672b9356aa650f11581a9d10b4a0ce96dfefad07e75959bb2d880422f2e14de1d4eec7203acc94b56449d3c208086fc0298')
+
+package() {
+ cd "${pkgdir}"
+ bsdtar -x -v -f "${srcdir}/data.tar.xz"
+ # Fix directory permissions
+ find . -type d -exec chmod -v 0755 {} \;
+}