summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-01-02 18:10:48 +0200
committerAdrian Perez de Castro2020-01-02 18:11:22 +0200
commitd4972ff7c4b5cbfab9bced455334fa282b1ca2a6 (patch)
tree9d2be8aba3bdea214cb99eae775460cb7f9ee4cf
parentf2d401a4ecf8ba2779ca7bb726e0f4d55d5525c7 (diff)
downloadaur-d4972ff7c4b5cbfab9bced455334fa282b1ca2a6.tar.gz
Bump to version 0.5.4
This also adds an upstream patch which is needed to build with GCC 9: https://github.com/parnold-x/nasc/commit/46b9b80e228b6b86001bded45d85e073a9411549
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--fix-gcc9-build.patch28
3 files changed, 42 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dab7c0d3a63b..9fd1803ea579 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nasc
pkgdesc = Do maths like a normal person.
- pkgver = 0.5.2
+ pkgver = 0.5.4
pkgrel = 1
url = https://parnold-x.github.io/nasc/
arch = i686
@@ -17,8 +17,10 @@ pkgbase = nasc
depends = cln
conflicts = nasc-git
conflicts = nasc-bzr
- source = https://github.com/parnold-x/nasc/archive/0.5.2.tar.gz
- sha512sums = b50e0d612144327198e841f76c1152879f91c70eae67c85e26fdd6839de1c4f26d1f4775158eade62a4a37f562b67c2f944e1feedfccf37324335aae3cf25eb3
+ source = https://github.com/parnold-x/nasc/archive/0.5.4.tar.gz
+ source = fix-gcc9-build.patch
+ sha512sums = ef06185182fc071adafe188a890e4751fdb515dda8ad87704203ba8dc123ede5d1e759031c1256581415bea3e31e4748f5235b94a15e1cbe21a19789d1763694
+ sha512sums = 0eacced70c0d831d07a7fa5199bd26f3b2fe3802bfd5038ce85240c2aff7c3223e52fa6b3d52dc4a35793c6c30cc796b9a797fed030c2f6f01462ecc2571a319
pkgname = nasc
diff --git a/PKGBUILD b/PKGBUILD
index ea3406853c7e..549ac4394cc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgname=nasc
-pkgver=0.5.2
+pkgver=0.5.4
pkgrel=1
pkgdesc='Do maths like a normal person.'
arch=('i686' 'x86_64')
@@ -10,8 +10,14 @@ depends=('libqalculate' 'granite' 'libgee' 'gtksourceview3' 'libsoup' 'cln')
optdepends=()
makedepends=('vala' 'git' 'cmake')
conflicts=('nasc-git' 'nasc-bzr')
-source=("https://github.com/parnold-x/nasc/archive/${pkgver}.tar.gz")
-sha512sums=('b50e0d612144327198e841f76c1152879f91c70eae67c85e26fdd6839de1c4f26d1f4775158eade62a4a37f562b67c2f944e1feedfccf37324335aae3cf25eb3')
+source=("https://github.com/parnold-x/nasc/archive/${pkgver}.tar.gz" fix-gcc9-build.patch)
+sha512sums=('ef06185182fc071adafe188a890e4751fdb515dda8ad87704203ba8dc123ede5d1e759031c1256581415bea3e31e4748f5235b94a15e1cbe21a19789d1763694'
+ '0eacced70c0d831d07a7fa5199bd26f3b2fe3802bfd5038ce85240c2aff7c3223e52fa6b3d52dc4a35793c6c30cc796b9a797fed030c2f6f01462ecc2571a319')
+
+prepare () {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 < "${srcdir}/fix-gcc9-build.patch"
+}
build () {
cd "${pkgname}-${pkgver}"
diff --git a/fix-gcc9-build.patch b/fix-gcc9-build.patch
new file mode 100644
index 000000000000..d20277e68907
--- /dev/null
+++ b/fix-gcc9-build.patch
@@ -0,0 +1,28 @@
+From 46b9b80e228b6b86001bded45d85e073a9411549 Mon Sep 17 00:00:00 2001
+From: Luigi Baldoni <aloisio@gmx.com>
+Date: Sun, 8 Dec 2019 12:03:01 +0100
+Subject: [PATCH] Fix build with gcc9
+
+---
+ libqalculatenasc/QalculateNasc.cc | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/libqalculatenasc/QalculateNasc.cc b/libqalculatenasc/QalculateNasc.cc
+index db0c09a..e6dc625 100644
+--- a/libqalculatenasc/QalculateNasc.cc
++++ b/libqalculatenasc/QalculateNasc.cc
+@@ -5,6 +5,7 @@
+ #include <thread>
+ #include <algorithm>
+
++using namespace std;
+ std::shared_ptr<Calculator> calc;
+ MathStructure *mstruct;
+
+@@ -275,4 +276,4 @@ std::string intern_calc (std::string input) {
+ std::string result_str = mstruct->print (printops);
+
+ return result_str;//calc->localizeExpression (result_str);
+-}
+\ No newline at end of file
++}