summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2020-12-30 19:43:35 -0500
committerKyle Keen2020-12-30 19:43:35 -0500
commit26b16fe2eeb283d1cd15e7a6bb6137b8ad0c382a (patch)
tree3cc9d983f55bd0b0430b702ca4c22c84ae637610
parentba2cf3c53af5aa160f23f09443cc054bbdd80e7c (diff)
downloadaur-26b16fe2eeb283d1cd15e7a6bb6137b8ad0c382a.tar.gz
correct url and repo, update build process
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3200f5746ef3..8e1b07dd75b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Thu Dec 31 00:43:23 UTC 2020
pkgbase = nasm-git
pkgdesc = 80x86 assembler designed for portability and modularity
- pkgver = 20150726
+ pkgver = 20201104
pkgrel = 1
- url = http://nasm.sourceforge.net/
+ url = https://www.nasm.us/
arch = i686
arch = x86_64
license = GPL
@@ -10,8 +12,8 @@ pkgbase = nasm-git
makedepends = asciidoc
depends = glibc
provides = nasm
- replaces = nasm
- source = git://repo.or.cz/nasm.git
+ conflicts = nasm
+ source = git://github.com/netwide-assembler/nasm.git
md5sums = SKIP
pkgname = nasm-git
diff --git a/PKGBUILD b/PKGBUILD
index 406cd3d9b909..2c2b7368e30d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Abakus <java5@arcor.de>
pkgname=nasm-git
-pkgver=20150726
+pkgver=20201104
pkgrel=1
pkgdesc="80x86 assembler designed for portability and modularity"
arch=('i686' 'x86_64')
-url="http://nasm.sourceforge.net/"
+url="https://www.nasm.us/"
depends=('glibc')
makedepends=('git' 'asciidoc')
license=('GPL')
-replaces=('nasm')
provides=('nasm')
-source=('git://repo.or.cz/nasm.git')
+conflicts=('nasm')
+source=('git://github.com/netwide-assembler/nasm.git')
md5sums=('SKIP')
_gitname="nasm"
@@ -23,21 +23,15 @@ pkgver() {
build() {
cd "$srcdir/$_gitname"
- #autoheader
- #autoconf
./autogen.sh
./configure --prefix=/usr
-
- # asciidoc/xmlto bugs out (report upstream)
- sed -i 's/manpages rdf/rdf/' Makefile
- sed -i 's/^.*\.1/#&/' Makefile
-
make
+ make manpages
+ make strip
}
package() {
cd "$srcdir/$_gitname"
- mkdir -p "$pkgdir/usr/"{bin,man/man1}
make prefix="$pkgdir/usr" install
}