summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2018-04-11 13:07:32 +0200
committerBrainDamage2018-04-11 13:07:32 +0200
commit213d8fe27a84bb98be2255558dae4a379ab0a1b5 (patch)
tree263b44bdaa261b1accc235314039905620dff732
downloadaur-213d8fe27a84bb98be2255558dae4a379ab0a1b5.tar.gz
initial version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a686330e32e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = naspro-core
+ pkgdesc = NASPRO core is the portable runtime library at the bottom of the NASPRO Architecture for Sound PROcessing.
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = http://naspro.sourceforge.net/libraries.html#naspro-core
+ arch = x86
+ arch = x86_64
+ license = LGPL
+ source = http://sourceforge.net/projects/naspro/files/naspro/0.5.1/naspro-core-0.5.1.tar.bz2
+ sha1sums = SKIP
+
+pkgname = naspro-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1f3e81f6280
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: BrainDamage
+pkgname="naspro-core"
+pkgrel=1
+pkgver=0.5.1
+pkgdesc="NASPRO core is the portable runtime library at the bottom of the NASPRO Architecture for Sound PROcessing."
+arch=('x86' 'x86_64')
+url="http://naspro.sourceforge.net/libraries.html#naspro-core"
+license=("LGPL")
+depends=()
+sha1sums=("SKIP")
+source=("http://sourceforge.net/projects/naspro/files/naspro/$pkgver/naspro-core-$pkgver.tar.bz2")
+
+
+build() {
+ cd "$srcdir/naspro-core-$pkgver"
+ #FIXME: deprecation of readdir_r, should be replaced with readdir
+ #https://sourceware.org/bugzilla/show_bug.cgi?id=19056
+ CFLAGS='-Wno-error' ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/naspro-core-$pkgver"
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file