summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Little2021-02-20 11:23:54 -0600
committerScott Little2021-02-20 11:23:54 -0600
commit9c22429360dd5dce58714039c0d701e3886a79d9 (patch)
treeda5ef525c147a9661aa99994ef0a9f6a479095f1
parentdbf0f573d02fb796ca8d8e5c4c0dd5da0ed4c2ad (diff)
downloadaur-9c22429360dd5dce58714039c0d701e3886a79d9.tar.gz
Switch to install
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD6
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ec38910e1b3..7019436add02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nat
pkgdesc = The Better ls
pkgver = 2.1.11
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/willdoescode/nat
arch = x86_64
license = MIT
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fdfa86dcc354
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+nat-*
+pkg
+src
+v*
diff --git a/PKGBUILD b/PKGBUILD
index 7378a05da09f..0c2aa9873174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Scott Little swlittle7 [at] gmail [dot] com
pkgname=nat
pkgver=2.1.11
-pkgrel=2
+pkgrel=3
epoch=
pkgdesc="The Better ls"
arch=(x86_64)
@@ -31,7 +31,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
- cargo install --path .
- mkdir -p "$pkgdir"/usr/local/bin
- cp ./target/release/natls "$pkgdir"/usr/local/bin
+ install -Dm755 target/release/natls "$pkgdir"/usr/local/bin/natls
}