summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-05-15 22:16:16 -0400
committerJean Lucas2018-05-15 22:16:16 -0400
commit576c00985541ec7f0484237ee0fdab589cc69748 (patch)
tree58514d053fa765c15905e5e8011c8e21d0b73721
downloadaur-576c00985541ec7f0484237ee0fdab589cc69748.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e80afca1c8b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed May 16 02:15:43 UTC 2018
+pkgbase = nativescript
+ pkgdesc = Create, build, and deploy NativeScript-based projects on iOS and Android devices
+ pkgver = 4.0.1
+ pkgrel = 1
+ url = https://www.npmjs.com/package/nativescript
+ arch = any
+ license = Apache
+ makedepends = npm
+ depends = nodejs
+ conflicts = nativescript-cli
+ noextract = nativescript-4.0.1.tgz
+ options = !emptydirs
+ options = !strip
+ source = http://registry.npmjs.org/nativescript/-/nativescript-4.0.1.tgz
+ sha512sums = 764c0e1261bf819757ba17867f2e2dd3cdf02e06835ded3163effb2692ee36b368eec053233e4f1b69bc273a3442745419680a9f2603d3b3667a58fffce02511
+
+pkgname = nativescript
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df472a0eb8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=nativescript
+pkgver=4.0.1
+pkgrel=1
+pkgdesc='Create, build, and deploy NativeScript-based projects on iOS and Android devices'
+arch=(any)
+url='https://www.npmjs.com/package/nativescript'
+license=(Apache)
+depends=(nodejs)
+makedepends=(npm)
+conflicts=(nativescript-cli)
+options=(!emptydirs !strip)
+source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+noextract=($pkgname-$pkgver.tgz)
+sha512sums=(764c0e1261bf819757ba17867f2e2dd3cdf02e06835ded3163effb2692ee36b368eec053233e4f1b69bc273a3442745419680a9f2603d3b3667a58fffce02511)
+
+package() {
+ npm install -g --prefix $pkgdir/usr $srcdir/$pkgname-$pkgver.tgz
+ find $pkgdir/usr -type d -exec chmod 755 {} +
+}