summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Gorodinskiy2017-11-14 22:29:54 +0100
committerKonstantin Gorodinskiy2017-11-14 22:36:41 +0100
commit607364033395f165a098d85d753e1125dfc14fa8 (patch)
treeefdcbd9db980d352fe565a13426097f38549e5a1
downloadaur-607364033395f165a098d85d753e1125dfc14fa8.tar.gz
1.0.0.v.2017.11.6.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD21
-rw-r--r--nativescript-sidekick.install27
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ed2dda71683
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = nativescript-sidekick
+ pkgdesc = NativeScript Sidekick is a desktop GUI that enhances the power of the NativeScript CLI and simplifies the development of mobile applications. It is designed to be a companion that complements your code editor, source control, and any other tools you use.
+ pkgver = 1.0.0.v.2017.11.6.3
+ pkgrel = 1
+ url = https://www.nativescript.org
+ install = nativescript-sidekick.install
+ arch = x86_64
+ license = custom
+ depends = desktop-file-utils
+ depends = gconf
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libnotify
+ depends = libxtst
+ depends = nss
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://dg336yfo7k.execute-api.us-east-1.amazonaws.com/live/update/official/linux/NativeScriptSidekick-amd64.deb
+ sha512sums_x86_64 = 76b4dad22486a7e639ffd3ed7d4f896c96a5f171486b219d626a45f0344208a479dcb33451a9db240f94e86fb3113a4404ea65dc01807a4028d2d93ff78262d8
+
+pkgname = nativescript-sidekick
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55857a508b41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Konstantin Gorodinskiy<mail@konstantin.io>
+pkgname=nativescript-sidekick
+pkgver=1.0.0.v.2017.11.6.3
+pkgrel=1
+pkgdesc="NativeScript Sidekick is a desktop GUI that enhances the power of the NativeScript CLI and simplifies the development of mobile applications. It is designed to be a companion that complements your code editor, source control, and any other tools you use."
+arch=('x86_64')
+url="https://www.nativescript.org"
+license=('custom')
+groups=('')
+depends=('desktop-file-utils' 'gconf' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libnotify' 'libxtst' 'nss')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://dg336yfo7k.execute-api.us-east-1.amazonaws.com/live/update/official/linux/NativeScriptSidekick-amd64.deb")
+sha512sums_x86_64=('76b4dad22486a7e639ffd3ed7d4f896c96a5f171486b219d626a45f0344208a479dcb33451a9db240f94e86fb3113a4404ea65dc01807a4028d2d93ff78262d8')
+
+package(){
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ install -d "${pkgdir}/${pkgname}/opt"
+ install -d "${pkgdir}/${pkgname}/usr/share"
+}
diff --git a/nativescript-sidekick.install b/nativescript-sidekick.install
new file mode 100644
index 000000000000..971df076c7bf
--- /dev/null
+++ b/nativescript-sidekick.install
@@ -0,0 +1,27 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/NativeScript Sidekick/NativeScript Sidekick' '/usr/bin/nssidekick'
+
+ # Link to the icon for older DMs
+ ln -sf '/usr/share/icons/hicolor/512x512/apps/NativeScriptSidekick.png' '/usr/share/pixmaps/NativeScriptSidekick.png'
+
+ update-desktop-database
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Unlink the binary and icon
+ rm -f '/usr/bin/nssidekick'
+ rm -f '/usr/share/pixmaps/NativeScriptSidekick.png'
+
+ update-desktop-database
+ update-desktop-database -q
+}