aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Francisco2020-04-16 02:41:12 +0100
committerXavier Francisco2020-04-16 02:41:12 +0100
commit1e7eda69b63bbac9ce7415e36006a812dbf795be (patch)
tree18c7a2be6574798adc6ee0af7233c7416c46ff90
parentd7ae098b3d0a52b777cfd581aa890c22938bbb78 (diff)
downloadaur-1e7eda69b63bbac9ce7415e36006a812dbf795be.tar.gz
Update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a1da607015a..f329f5d5dd79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nato-spell-git
pkgdesc = Spelling engine for the NATO phonetic alphabet
- pkgver = 0.2.1
+ pkgver = 0.3.1.r0.g575f3e3
pkgrel = 1
url = https://github.com/Qu4tro/nato-spell
arch = i686
@@ -9,7 +9,7 @@ pkgbase = nato-spell-git
makedepends = git
makedepends = sed
makedepends = python-setuptools
- makedepends = python-dephell
+ makedepends = python-poetry
depends = alsa-utils
depends = python
provides = nato-spell
diff --git a/PKGBUILD b/PKGBUILD
index fead1377cbee..2cd67a84f8da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# PKGBUILD script for nato-spell upstream, git version
_pkgname=nato-spell
+_pkgver=0.3.1
pkgname=$_pkgname-git
-pkgver=0.2.1
+pkgver=0.3.1.r0.g575f3e3
pkgrel=1
pkgdesc="Spelling engine for the NATO phonetic alphabet"
arch=('i686' 'x86_64')
@@ -11,7 +12,7 @@ url="https://github.com/Qu4tro/nato-spell"
license=('MIT')
groups=()
depends=('alsa-utils' 'python')
-makedepends=('git' 'sed' 'python-setuptools' 'python-dephell')
+makedepends=('git' 'sed' 'python-setuptools' 'python-poetry')
# optdepends=('***: for that thing *** does')
provides=("$_pkgname")
conflicts=("$_pkgname")
@@ -23,7 +24,9 @@ pkgdir="/usr/lib"
prepare() {
cd "$_pkgname"
- dephell deps convert --from pyproject.toml --to setup.py
+ poetry build
+ cd dist
+ tar -xf "$_pkgname-$_pkgver.tar.gz"
}
pkgver() {
@@ -32,11 +35,12 @@ pkgver() {
}
build() {
- cd "$_pkgname"
+ cd "$_pkgname/dist/$_pkgname-$_pkgver"
+
python setup.py build
}
package() {
- cd "$_pkgname"
+ cd "$_pkgname/dist/$_pkgname-$_pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}