aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Francisco2020-04-14 00:27:52 +0100
committerXavier Francisco2020-04-14 00:27:52 +0100
commitd7ae098b3d0a52b777cfd581aa890c22938bbb78 (patch)
tree171c6ac81412b414794c4536bb6431f8eb18ebf1
downloadaur-d7ae098b3d0a52b777cfd581aa890c22938bbb78.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD42
-rw-r--r--README.md2
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a1da607015a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = nato-spell-git
+ pkgdesc = Spelling engine for the NATO phonetic alphabet
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/Qu4tro/nato-spell
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = sed
+ makedepends = python-setuptools
+ makedepends = python-dephell
+ depends = alsa-utils
+ depends = python
+ provides = nato-spell
+ conflicts = nato-spell
+ backup = etc/nato-spell/nato-spell.conf
+ source = nato-spell::git+https://github.com/Qu4tro/nato-spell.git
+ md5sums = SKIP
+
+pkgname = nato-spell-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e6c32eb8c23e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Xavier Francisco
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fead1377cbee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Xavier Francisco <echo moc.liamg@ocsicnarf.n.reivax | rev>
+
+# PKGBUILD script for nato-spell upstream, git version
+_pkgname=nato-spell
+pkgname=$_pkgname-git
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Spelling engine for the NATO phonetic alphabet"
+arch=('i686' 'x86_64')
+url="https://github.com/Qu4tro/nato-spell"
+license=('MIT')
+groups=()
+depends=('alsa-utils' 'python')
+makedepends=('git' 'sed' 'python-setuptools' 'python-dephell')
+# optdepends=('***: for that thing *** does')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+backup=("etc/$_pkgname/$_pkgname.conf")
+source=("$_pkgname::git+https://github.com/Qu4tro/nato-spell.git")
+md5sums=('SKIP')
+pkgdir="/usr/lib"
+
+
+prepare() {
+ cd "$_pkgname"
+ dephell deps convert --from pyproject.toml --to setup.py
+}
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..0103a100cc96
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# nato-spell-pkgbuild
+PKGBUILD for nato spell extension