summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-11-21 07:47:32 +0100
committerLuca Weiss2016-11-21 07:47:32 +0100
commit66d253e19963bea9d6fff7197ef195b61f2069e9 (patch)
tree37a685b3de5f72c5606850f4b2474ec5b9f88c87
parent69abc233c5723141494556e878e9e8006ef9988e (diff)
downloadaur-66d253e19963bea9d6fff7197ef195b61f2069e9.tar.gz
stuff
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d46957636d34..f16219480013 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Nov 20 20:10:56 UTC 2016
+# Mon Nov 21 06:47:27 UTC 2016
pkgbase = natron
pkgdesc = Open source compositing software. Node-graph based. Similar in functionalities to Adobe After Effects and Nuke by The Foundry.
pkgver = 2.1.8
@@ -22,11 +22,12 @@ pkgbase = natron
depends = openfx-io
depends = openfx-misc
optdepends = openfx-arena: Extra OpenFX plugins for Natron includes text node
- source = natron::git://github.com/MrKepzie/Natron.git#tag=2.1.8
+ source = natron::git+https://github.com/MrKepzie/Natron.git#tag=2.1.8
source = git+https://github.com/devernay/openfx.git
source = git+https://github.com/MrKepzie/google-test.git
source = git+https://github.com/MrKepzie/google-mock.git
source = git+https://github.com/MrKepzie/SequenceParsing.git
+ source = git+https://github.com/MrKepzie/tinydir
source = https://github.com/MrKepzie/OpenColorIO-Configs/archive/Natron-v2.1.tar.gz
source = config.pri
md5sums = SKIP
@@ -34,6 +35,7 @@ pkgbase = natron
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
md5sums = 4ca4eca4856cae50cfa4645a090258dd
md5sums = 09f5ac67c0ad57eb853141b38eccb0ff
diff --git a/PKGBUILD b/PKGBUILD
index cb7d3826dd43..e38777630cde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,11 +11,12 @@ license=("GPL")
depends=('fontconfig' 'qt4' 'python2-pyside' 'python2-shiboken' 'boost-libs' 'pixman' 'glfw-x11' 'cairo' 'openfx-io' 'openfx-misc')
makedepends=('git' 'expat' 'boost')
optdepends=('openfx-arena: Extra OpenFX plugins for Natron includes text node')
-source=("$pkgname::git://github.com/MrKepzie/Natron.git#tag=$pkgver"
+source=("$pkgname::git+https://github.com/MrKepzie/Natron.git#tag=$pkgver"
"git+https://github.com/devernay/openfx.git"
"git+https://github.com/MrKepzie/google-test.git"
"git+https://github.com/MrKepzie/google-mock.git"
"git+https://github.com/MrKepzie/SequenceParsing.git"
+ "git+https://github.com/MrKepzie/tinydir"
"https://github.com/MrKepzie/OpenColorIO-Configs/archive/Natron-v${pkgver%.*}.tar.gz"
"config.pri")
md5sums=('SKIP'
@@ -23,6 +24,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'4ca4eca4856cae50cfa4645a090258dd'
'09f5ac67c0ad57eb853141b38eccb0ff')
@@ -37,7 +39,12 @@ prepare() {
git config submodule.Tests/google-test.url $srcdir/google-test
git config submodule.libs/SequenceParsing.url $srcdir/SequenceParsing
git submodule update
-
+
+ cd libs/SequenceParsing
+ git config submodule.tinydir.url $srcdir/tinydir
+ git submodule update
+ cd ../..
+
mv "${srcdir}/config.pri" "${srcdir}/${pkgname%%-*}/config.pri"
# Fix for gcc6 build issues
sed -i '1s/^/QMAKE_CXXFLAGS += -std=c++98\n/' Gui/Gui.pro