summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan2016-11-15 17:39:42 -0400
committerJuan2016-11-15 17:39:42 -0400
commit87839aac1d1283635e893b66f7e0642f4dd337b8 (patch)
tree172a438ff5f62b11b22dcb16732cf2ce8e364232
downloadaur-87839aac1d1283635e893b66f7e0642f4dd337b8.tar.gz
hello
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD30
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0d3d4d3f668
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = natron-plugins
+ pkgdesc = Extra OpenFX plugins for Natron
+ pkgver = 2.1.7
+ pkgrel = 1
+ url = https://github.com/olear/openfx-arena/tree/Natron-2.1.7
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = swig
+ depends = swig2
+ depends = boost
+ depends = boost-libs
+ depends = freetype2
+ depends = openexr
+ depends = libraw
+ depends = openjpeg
+ depends = graphviz
+ depends = libxt
+ depends = bzip2
+ depends = libtool
+ depends = libcaca
+ depends = libjpeg
+ depends = libtiff
+ depends = glew
+ depends = libpng
+ depends = lcms
+ depends = gcc-libs-multilib
+ depends = imagemagick
+ depends = libcdr
+ depends = librsvg
+ depends = libtool
+ depends = libzip
+ depends = opencolorio
+ depends = poppler-glib
+ source = natron-plugins::git://github.com/NatronVFX/natron-plugins.git#tag=2.1.7
+ md5sums = SKIP
+
+pkgname = natron-plugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91ef6b053b5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
+pkgname=natron-plugins
+pkgver=2.1.7
+pkgrel=1
+arch=("i686" "x86_64")
+pkgdesc="Extra OpenFX plugins for Natron"
+url="https://github.com/olear/openfx-arena/tree/Natron-$pkgver"
+license=("GPL2")
+makedepends=("git")
+depends=("swig" "swig2" "boost" "boost-libs" "freetype2" "openexr" "libraw" "openjpeg" "graphviz" "libxt" "bzip2" "libtool" "libcaca" "libjpeg" "libtiff" "glew" "libpng" "lcms" "gcc-libs-multilib" "imagemagick" "libcdr" "librsvg" "libtool" "libzip" "opencolorio" "poppler-glib" )
+source=("$pkgname::git://github.com/NatronVFX/natron-plugins.git#tag=$pkgver")
+md5sums=("SKIP")
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update -i --recursive
+ #cd "OpenFX"
+ #note : patch is only useful for 2.1.2 & lower. should be fixed in next release
+ #patch -uNp1 -i $srcdir/GCC6.patch
+
+}
+
+
+
+package() {
+ cd $srcdir/$pkgname/
+ mkdir -p "$pkgdir/usr/share/Natron/Plugins"
+
+ cp -r * $pkgdir/usr/share/Natron/Plugins/
+}