summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan2016-12-17 20:22:49 -0400
committerJuan2016-12-17 20:22:49 -0400
commitc6e7ad1dbb28bf3393c71d8122272c89056cf919 (patch)
tree823f57b5539814017485f01ffd7fa47897f0d6b3
parent6e38590478a58f4e7ab1bd4cb165b91c220ca853 (diff)
downloadaur-c6e7ad1dbb28bf3393c71d8122272c89056cf919.tar.gz
git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 794f35e3467e..4811129e03ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = natron-plugins
pkgdesc = Extra OpenFX plugins for Natron
- pkgver = 2.1.7
- pkgrel = 2
+ pkgver = 234
+ pkgrel = 1
url = https://github.com/NatronVFX/natron-plugins
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = natron-plugins
depends = python
depends = python2
depends = ffmpeg
- source = natron-plugins::git://github.com/NatronVFX/natron-plugins.git#tag=2.1.7
+ source = natron-plugins::git://github.com/NatronVFX/natron-plugins.git
md5sums = SKIP
pkgname = natron-plugins
diff --git a/PKGBUILD b/PKGBUILD
index 74aab823c4ba..d79c3f920363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,22 @@
# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
pkgname=natron-plugins
-pkgver=2.1.7
-pkgrel=2
+pkgver=234
+pkgrel=1
arch=("i686" "x86_64")
pkgdesc="Extra OpenFX plugins for Natron"
url="https://github.com/NatronVFX/natron-plugins"
license=("GPL2")
makedepends=("git")
depends=("natron" "python" "python2" "ffmpeg")
-source=("$pkgname::git://github.com/NatronVFX/natron-plugins.git#tag=$pkgver")
+source=("$pkgname::git://github.com/NatronVFX/natron-plugins.git")
md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git rev-list --count HEAD
+}
+
prepare() {
cd "$srcdir/$pkgname"
git submodule update -i --recursive