summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2019-04-06 21:58:26 +0200
committergéballin2019-04-06 21:58:26 +0200
commitf14e1ee2e67b2070ece241b6cb832636a73937d7 (patch)
tree95fa697f2b4b80c304eff43f1ca6c552bcecf3a1
downloadaur-f14e1ee2e67b2070ece241b6cb832636a73937d7.tar.gz
First commit for the version 2 of natural docs.
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD30
-rwxr-xr-xnaturaldocs22
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db3b2a72714d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = naturaldocs2
+ pkgdesc = Readable Source Code Documentation for 20 Programming Languages
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://www.naturaldocs.org/
+ arch = x86_64
+ arch = i686
+ license = AGPLv3
+ depends = mono
+ source = https://www.naturaldocs.org/download/natural_docs/2.0.2/Natural_Docs_2.0.2.zip
+ source = naturaldocs2
+ md5sums = 020c0badd8d1c8c4f25f5d035dc592de
+ md5sums = 92ec6333b5df1367b8464d0a0f06f49d
+
+pkgname = naturaldocs2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f12a33a9538b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=naturaldocs2
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="Readable Source Code Documentation for 20 Programming Languages"
+url="https://www.naturaldocs.org/"
+arch=('x86_64' 'i686')
+license=('AGPLv3')
+depends=(mono)
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://www.naturaldocs.org/download/natural_docs/${pkgver}/Natural_Docs_${pkgver}.zip" naturaldocs2)
+
+md5sums=('020c0badd8d1c8c4f25f5d035dc592de' '92ec6333b5df1367b8464d0a0f06f49d')
+
+build() {
+ cd "${srcdir}/Natural Docs/"
+ }
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/${pkgname}/"
+ mv "${srcdir}/Natural Docs" naturaldocs
+ rsync -a ${srcdir}/naturaldocs/ "${pkgdir}/usr/share/${pkgname}/"
+ mkdir -p ${pkgdir}/usr/bin/
+ cp ${srcdir}/naturaldocs2 ${pkgdir}/usr/bin/
+ }
diff --git a/naturaldocs2 b/naturaldocs2
new file mode 100755
index 000000000000..1fd7d0f4a061
--- /dev/null
+++ b/naturaldocs2
@@ -0,0 +1,2 @@
+#! /usr/bin/env sh
+mono `dirname $0`/../share/naturaldocs2/NaturalDocs.exe $@