summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Nova2015-06-08 20:56:15 +0100
committerBruno Nova2015-06-08 20:56:15 +0100
commit4c5a67efedc4bf40fcea33845cfbc1ea57d2d16d (patch)
treefcd1fbb0f968dfa2499c4c88479371ce904db532
downloadaur-4c5a67efedc4bf40fcea33845cfbc1ea57d2d16d.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD26
-rw-r--r--nautilus-admin.install3
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e42f0a8a2504
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.0
+# Tue May 26 09:19:21 UTC 2015
+pkgbase = nautilus-admin
+ pkgdesc = Extension for Nautilus to do administrative operations
+ pkgver = 0.1.2
+ pkgrel = 2
+ url = https://bitbucket.org/brunonova/nautilus-admin
+ install = nautilus-admin.install
+ arch = any
+ license = GPL3
+ makedepends = cmake>=2.6
+ makedepends = gettext
+ depends = nautilus
+ depends = python-nautilus
+ depends = polkit
+ depends = gconf
+ optdepends = gedit: to use the "Edit as Administrator" action
+ source = https://bitbucket.org/brunonova/nautilus-admin/downloads/nautilus-admin_0.1.2.tar.xz
+ md5sums = 49432e939f9454dcea18a66f2dfe2421
+
+pkgname = nautilus-admin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2555403f926f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Bruno Nova <brunomb.nova@gmail.com>
+pkgname=nautilus-admin
+pkgver=0.1.2
+pkgrel=2
+pkgdesc="Extension for Nautilus to do administrative operations"
+arch=('any')
+url="https://bitbucket.org/brunonova/nautilus-admin"
+license=('GPL3')
+depends=('nautilus' 'python-nautilus' 'polkit' 'gconf')
+makedepends=('cmake>=2.6' 'gettext')
+optdepends=('gedit: to use the "Edit as Administrator" action')
+install="$pkgname.install"
+source=("https://bitbucket.org/brunonova/$pkgname/downloads/${pkgname}_$pkgver.tar.xz")
+md5sums=('49432e939f9454dcea18a66f2dfe2421')
+
+build() {
+ cd "$srcdir"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "README.mkd" "$pkgdir/usr/share/doc/$pkgname/README.mkd"
+}
diff --git a/nautilus-admin.install b/nautilus-admin.install
new file mode 100644
index 000000000000..d73966f2f3ce
--- /dev/null
+++ b/nautilus-admin.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo 'Nautilus, if running, must be restarted for this extension to work (execute "nautilus -q").'
+}