summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2020-10-08 14:15:40 +0100
committergrufo2020-10-08 14:15:40 +0100
commit511803e791a29d31be4e08c09f5440305db504e4 (patch)
treedff5d3e36ccd7a81cf09bb4db2a5ab8db9d1ff57
parent97bbace8836ecaabdd16e1ce83c69b7e6752f8f8 (diff)
downloadaur-511803e791a29d31be4e08c09f5440305db504e4.tar.gz
Bump version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD30
2 files changed, 14 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d06bd26f92f6..c23339ac13de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = nautilus-bluetooth-git
pkgdesc = A simple Nautilus extension that adds a "Send via Bluetooth" entry to Nautilus' right-click menu
- pkgver = r7.d4401da
+ pkgver = r10.65d378c
pkgrel = 1
url = https://gitlab.gnome.org/madmurphy/nautilus-bluetooth
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL
makedepends = pkgconf
makedepends = intltool
diff --git a/PKGBUILD b/PKGBUILD
index bda93023b233..bd864112fbf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,45 @@
# Maintainer: grufo <madmurphy333 AT gmail DOT com>
pkgname='nautilus-bluetooth-git'
-_appname='nautilus-bluetooth'
-pkgver='r7.d4401da'
+_extname='nautilus-bluetooth'
+pkgver='r10.65d378c'
pkgrel=1
pkgdesc="A simple Nautilus extension that adds a \"Send via Bluetooth\" entry to Nautilus' right-click menu"
-arch=('any')
+arch=('i686' 'x86_64')
url="https://gitlab.gnome.org/madmurphy/nautilus-bluetooth"
license=('GPL')
depends=('glib2' 'libnautilus-extension' 'gnome-bluetooth')
makedepends=('pkgconf' 'intltool')
-provides=("${_appname}")
-conflicts=("${_appname}" "${_appname}-bin")
-source=("git+https://gitlab.gnome.org/madmurphy/${_appname}.git")
+provides=("${_extname}")
+conflicts=("${_extname}" "${_extname}-bin")
+source=("git+https://gitlab.gnome.org/madmurphy/${_extname}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${_appname}"
+ cd "${_extname}"
printf "'r%s.%s'" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}/${_appname}"
- ./autogen.sh --noconfigure
+ cd "${srcdir}/${_extname}"
+ ./bootstrap --noconfigure
./configure --prefix=/usr
}
build() {
- cd "${srcdir}/${_appname}"
+ cd "${srcdir}/${_extname}"
make
}
-
-check() {
-
- cd "${srcdir}/${_appname}"
- make check
-
-}
-
package() {
- cd "${srcdir}/${_appname}"
+ cd "${srcdir}/${_extname}"
make DESTDIR="${pkgdir}" install
}